summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-10-13 17:20:41 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-10-13 17:20:41 +0000
commit6bed9d56b66a461f1cdc4b672ce10bc39a88baca (patch)
tree5361b51f74d96efb7749d356e4d1c47fffcc4f40 /configure.in
parentb77f3f9ba3fc98c086d01440eef7771c58f9058d (diff)
downloadpango-6bed9d56b66a461f1cdc4b672ce10bc39a88baca.tar.gz
Bug 361938 – Can't include *-lang modules (./configure
2006-10-13 Behdad Esfahbod <behdad@gnome.org> Bug 361938 – Can't include *-lang modules (./configure --with-included-modules fails) * configure.in: * modules/Makefile.am: * pango/.cvsignore: * pango/Makefile.am: * pango/modules.c (init_modules): * pango/modules.h: Make included language engines work.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 33 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 36120426..ced5ea83 100644
--- a/configure.in
+++ b/configure.in
@@ -447,11 +447,13 @@ INCLUDED_X_MODULES=
INCLUDED_FC_MODULES=
INCLUDED_WIN32_MODULES=
INCLUDED_ATSUI_MODULES=
+INCLUDED_LANG_MODULES=
AC_SUBST(INCLUDED_X_MODULES)
AC_SUBST(INCLUDED_FC_MODULES)
AC_SUBST(INCLUDED_WIN32_MODULES)
AC_SUBST(INCLUDED_ATSUI_MODULES)
+AC_SUBST(INCLUDED_LANG_MODULES)
IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=", "
for module in $included_modules; do
@@ -462,10 +464,11 @@ for module in $included_modules; do
included_path="\$(top_builddir)/modules/$dir/libpango-$module.la"
case $module in
- *-fc) INCLUDED_FC_MODULES="$INCLUDED_FC_MODULES $included_path" ;;
*-x) INCLUDED_X_MODULES="$INCLUDED_X_MODULES $included_path" ;;
+ *-fc) INCLUDED_FC_MODULES="$INCLUDED_FC_MODULES $included_path" ;;
*-win32) INCLUDED_WIN32_MODULES="$INCLUDED_WIN32_MODULES $included_path" ;;
*-atsui) INCLUDED_ATSUI_MODULES="$INCLUDED_ATSUI_MODULES $included_path" ;;
+ *-lang) INCLUDED_LANG_MODULES="$INCLUDED_LANG_MODULES $included_path" ;;
*) AC_MSG_ERROR([specified module $module not recognized]) ;;
esac
done
@@ -803,6 +806,35 @@ cat >> pango/module-defs-atsui.c <<EOTEXT
EOTEXT
])
+AC_CONFIG_COMMANDS([pango/module-defs-lang.c],
+[
+### lang modules
+cat > pango/module-defs-lang.c <<EOTEXT
+/* Autogenerated by configure. Do not edit */
+
+#include "module-defs.h"
+
+PangoIncludedModule _pango_included_lang_modules@<:@@:>@ = {
+EOTEXT
+
+IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
+for module in $included_modules; do
+ if echo $module | egrep -- "-lang($|,)" > /dev/null; then
+ module_c=`echo $module | sed s/-/_/`
+ cat >> pango/module-defs-lang.c <<EOTEXT
+ { _pango_${module_c}_script_engine_list, _pango_${module_c}_script_engine_init, _pango_${module_c}_script_engine_exit, _pango_${module_c}_script_engine_create },
+EOTEXT
+ fi
+done
+
+IFS="$pango_save_ifs"
+
+cat >> pango/module-defs-lang.c <<EOTEXT
+ { NULL, NULL, NULL, NULL },
+};
+EOTEXT
+])
+
AC_HEADER_DIRENT
AC_CHECK_HEADERS(unistd.h)