summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-09-18 22:11:32 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-09-18 22:11:32 +0000
commitad3912db10e1f337e9c227524b36e346bbe1328d (patch)
tree989a1e6408ceb134b3e56cc8c98ee36e022eec29 /configure.in
parenta83cf48e725c69f131b833a65069db3f05b0b52f (diff)
downloadpango-ad3912db10e1f337e9c227524b36e346bbe1328d.tar.gz
Part of Bug 350132 – backspacing doesn't work properly for Arabic
2006-09-18 Behdad Esfahbod <behdad@gnome.org> Part of Bug 350132 – backspacing doesn't work properly for Arabic * configure.in: * modules/arabic/Makefile.am: * modules/arabic/arabic-lang.c: Add a simple Arabic language engine. Currently it just makes sure that backspace_deletes_character is not set on ALEF-MADDA combinations.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 39132fec..e6610f6e 100644
--- a/configure.in
+++ b/configure.in
@@ -394,7 +394,7 @@ fi
#
# Modules to build
#
-arabic_modules="arabic-fc"
+arabic_modules="arabic-fc,arabic-lang"
basic_modules="basic-fc,basic-win32,basic-x,basic-atsui"
hangul_modules="hangul-fc"
hebrew_modules="hebrew-fc"
@@ -472,6 +472,7 @@ done
IFS="$pango_save_ifs"
AM_CONDITIONAL(INCLUDE_ARABIC_FC, echo $included_modules | egrep '(^|,)arabic-fc($|,)' > /dev/null)
+AM_CONDITIONAL(INCLUDE_ARABIC_LANG, echo $included_modules | egrep '(^|,)arabic-lang($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_FC, echo $included_modules | egrep '(^|,)basic-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_WIN32, echo $included_modules | egrep '(^|,)basic-win32($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_X, echo $included_modules | egrep '(^|,)basic-x($|,)' > /dev/null)
@@ -485,6 +486,7 @@ AM_CONDITIONAL(INCLUDE_THAI_FC, echo $included_modules | egrep '(^|,)thai-fc($|
AM_CONDITIONAL(INCLUDE_TIBETAN_FC, echo $included_modules | egrep '(^|,)tibetan-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_ARABIC_FC, echo $dynamic_modules | egrep '(^|,)arabic-fc($|,)' > /dev/null)
+AM_CONDITIONAL(DYNAMIC_ARABIC_LANG, echo $dynamic_modules | egrep '(^|,)arabic-lang($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_FC, echo $dynamic_modules | egrep '(^|,)basic-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_WIN32, echo $dynamic_modules | egrep '(^|,)basic-win32($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_X, echo $dynamic_modules | egrep '(^|,)basic-x($|,)' > /dev/null)