summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2008-04-21 19:50:21 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2008-04-21 19:50:21 +0000
commit18348c428c2515bd6b0c4b3e97aaf9b0661e9d12 (patch)
treea28ff908ef2ba4d1c1e213310f9b794b0dc46302 /configure.in
parente026cad714ef709b680efa8489012b823665d7e7 (diff)
downloadpango-18348c428c2515bd6b0c4b3e97aaf9b0661e9d12.tar.gz
Require cairo >= 1.6.4. Remove compat cruft that were added to support
2008-04-21 Behdad Esfahbod <behdad@gnome.org> * configure.in: * pango/pangocairo-atsui.h: * pango/pangocairo-atsuifont.c (pango_cairo_atsui_font_create_font_face): * pango/pangocairo-fontmap.c (pango_cairo_font_map_new_for_font_type): Require cairo >= 1.6.4. Remove compat cruft that were added to support older cairo that had cairo-atsui instead of cairo-quartz-font. svn path=/trunk/; revision=2601
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 7a1ec766..d0458847 100644
--- a/configure.in
+++ b/configure.in
@@ -320,7 +320,7 @@ have_cairo_xlib=false
have_cairo_freetype=false
have_cairo_win32=false
have_cairo_atsui=false
-cairo_required=1.2.6
+cairo_required=1.6.4
PKG_CHECK_MODULES(CAIRO, cairo >= $cairo_required, have_cairo=true, AC_MSG_RESULT([no]))
@@ -338,7 +338,7 @@ if $have_cairo ; then
PKG_CHECK_EXISTS(cairo-win32 >= $cairo_required, have_cairo_win32=true, :)
fi
if $have_cairo_win32; then
- AC_DEFINE(HAVE_CAIRO_WIN32, 1, [Whether Cairo uses the Win32 GDI for fonts])
+ AC_DEFINE(HAVE_CAIRO_WIN32, 1, [Whether Cairo can use the Win32 GDI for fonts])
have_cairo=true
fi
@@ -346,17 +346,15 @@ if $have_cairo ; then
PKG_CHECK_EXISTS(cairo-ft >= $cairo_required, have_cairo_freetype=true, :)
fi
if $have_cairo_freetype; then
- AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo uses FreeType for fonts])
+ AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo can use FreeType for fonts])
have_cairo=true
fi
if $have_atsui; then
- # for transition from old cairo-atsui to new cairo-quartz-font
- PKG_CHECK_EXISTS(cairo-atsui >= $cairo_required, have_cairo_atsui=true, :)
PKG_CHECK_EXISTS(cairo-quartz-font >= $cairo_required, have_cairo_atsui=true, :)
fi
if $have_cairo_atsui; then
- AC_DEFINE(HAVE_CAIRO_ATSUI, 1, [Whether Cairo uses ATSUI for fonts])
+ AC_DEFINE(HAVE_CAIRO_ATSUI, 1, [Whether Cairo can use ATSUI for fonts])
have_cairo=true
fi