summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2008-08-05 23:12:13 +0000
committerTor Lillqvist <tml@src.gnome.org>2008-08-05 23:12:13 +0000
commit32d2f52bf481f6e7df178d53b67721846deb9120 (patch)
tree13bbd03b9779a44f258ebcc5d9240940ee1e90fd /configure.in
parent5da782e5070262f6b8494ee987cde3a8d7d51d78 (diff)
downloadpango-32d2f52bf481f6e7df178d53b67721846deb9120.tar.gz
On Windows set LIB_EXE_MACHINE_FLAG to X86 or X64 depending on host
2008-08-06 Tor Lillqvist <tml@novell.com> * configure.in: On Windows set LIB_EXE_MACHINE_FLAG to X86 or X64 depending on host architecture. * pango/Makefile.am: Use it when running lib.exe. svn path=/trunk/; revision=2670
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 26dcfd01..f528fcaf 100644
--- a/configure.in
+++ b/configure.in
@@ -88,12 +88,23 @@ AC_MSG_CHECKING([for native Win32])
case "$host" in
*-*-mingw*)
pango_os_win32=yes
+ case "$host" in
+ x86_64-*-*)
+ LIB_EXE_MACHINE_FLAG=X64
+ ;;
+ *)
+ LIB_EXE_MACHINE_FLAG=X86
+ ;;
+ esac
;;
*)
pango_os_win32=no
;;
esac
AC_MSG_RESULT([$pango_os_win32])
+
+AC_SUBST(LIB_EXE_MACHINE_FLAG)
+
AM_CONDITIONAL(OS_WIN32, test "$pango_os_win32" = "yes")
AC_PROG_CC