summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-03-02 23:18:32 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-03-02 23:18:32 +0000
commitcd9e68bea720226c840cdf0babfd3f465f027aed (patch)
tree9bc00a07798587e4a47ac6f7424ecfd865888b40 /configure.in
parent329c7a4b5be9a071fee983e2e78484c9a39ef0f8 (diff)
downloadpango-cd9e68bea720226c840cdf0babfd3f465f027aed.tar.gz
Default to --disable-static.
Fri Mar 1 00:46:49 2002 Owen Taylor <otaylor@redhat.com> * configure: Default to --disable-static. * configure.in pangoft2.pc.in pangoxft2.pc.in pangox.pc.in: Add a --enable-explicit-deps option to control whether dependency libraries are written into .la files and .pc files. Default is auto: if static libraries are off and shlib dependencies are found, don't write deps. * pango/Makefile.am sanitize-la.sh: Shell script used to strip dependencies out of .la files. * configure.in: Default to --disable-gtk-doc. * Makefile.am: Add a slightly modified distcheck rule that passes --enable-gtk-doc to the configure inside. (So that 'make dist' succeeds inside.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 43 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 9f153fb7..b18af8f3 100644
--- a/configure.in
+++ b/configure.in
@@ -26,6 +26,7 @@ AM_CONDITIONAL(HAVE_CXX, test "$CXX" != "")
AC_LANG_RESTORE
AC_LIBTOOL_WIN32_DLL
+AM_DISABLE_STATIC
AM_PROG_LIBTOOL
AM_PROG_LEX
AC_PROG_YACC
@@ -68,8 +69,6 @@ if test "x$GCC" = "xyes"; then
fi
changequote([,])dnl
-AC_PATH_XTRA
-
AC_ARG_ENABLE(rebuilds, [ --disable-rebuilds disable all source autogeneration rules],,enable_rebuilds=yes)
# define a MAINT-like variable REBUILD which is set if Perl
@@ -85,6 +84,8 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
+AC_PATH_XTRA
+
if test x$no_x = xyes ; then
AC_MSG_WARN([X development libraries not found])
have_x=false
@@ -465,7 +466,7 @@ AC_CHECK_PROG(DB2HTML, db2html, true, false)
AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
dnl Let people disable the gtk-doc stuff.
-AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc use gtk-doc to build documentation [default=auto]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
+AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc use gtk-doc to build documentation [default=no]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
if test x$enable_gtk_doc = xauto ; then
if test x$GTKDOC = xtrue ; then
@@ -479,6 +480,45 @@ dnl NOTE: We need to use a separate automake conditional for this
dnl to make this work with the tarballs.
AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+dnl ******************************************************
+dnl * See whether to include shared library dependencies *
+dnl ******************************************************
+
+AC_ARG_ENABLE(explicit-deps,
+ [ --enable-explicit-deps=[yes/no/auto] use explicit dependencies in .pc files [default=auto]],
+ enable_explicit_deps="$enableval",
+ enable_explicit_deps=auto)
+
+AC_MSG_CHECKING([Whether to write dependencies into .pc files])
+case $enable_explicit_deps in
+ auto)
+ deplib_check_method=`(./libtool --config; echo eval echo \\$deplib_check_method) | sh`
+ if test "X$deplib_check_method" == Xnone || test "x$enable_static" = xyes ; then
+ enable_explicit_deps=yes
+ else
+ enable_explicit_deps=no
+ fi
+ ;;
+ yes|no)
+ ;;
+ *) AC_MSG_ERROR([Value given to --enable-explicit-deps must be one of yes, no or auto])
+ ;;
+esac
+AC_MSG_RESULT($enable_explicit_deps)
+
+if test $enable_explicit_deps = yes ; then
+ PKGCONFIG_X_LIBS=$X_LIBS@ $X_EXTRA_LIBS
+ PKGCONFIG_XFT_LIBS=$XFT_LIBS
+ PKGCONFIG_FREETYPE_LIBS=$XFT_LIBS
+else
+ PKGCONFIG_X_LIBS=
+ PKGCONFIG_XFT_LIBS=
+ PKGCONFIG_FREETYPE_LIBS=
+fi
+AC_SUBST(PKGCONFIG_X_LIBS)
+AC_SUBST(PKGCONFIG_XFT_LIBS)
+AC_SUBST(PKGCONFIG_FREETYPE_LIBS)
+AM_CONDITIONAL(DISABLE_EXPLICIT_DEPS, test $enable_explicit_deps = no)
AC_OUTPUT_COMMANDS([
cat > pango/module-defs.h <<EOTEXT