summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-08-20 20:20:17 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-08-20 20:20:17 +0000
commit2ff1f7400ae539940539da019a4aef2de9152687 (patch)
tree97172d14529af3e83f3df872817f5a103921cea7 /configure.in
parent872a43c7801106a02373899db39e684b4747bbaa (diff)
downloadpango-2ff1f7400ae539940539da019a4aef2de9152687.tar.gz
Make the test for VARARGS macros more robust, fixing problem with
Tue Aug 20 16:06:36 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Make the test for VARARGS macros more robust, fixing problem with misbehaving IRIX compiler that doesn't error on #error. (#90267)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 06489d71..5b270d81 100644
--- a/configure.in
+++ b/configure.in
@@ -315,15 +315,19 @@ fi
# The OpenType test programs aren't particularly portable
#
have_varargs=no
+pango_saved_cppflags=$CPPFLAGS
+CPPFLAGS="$CPPFLAGS $GLIB_CFLAGS"
AC_MSG_CHECKING(Whether to build OpenType test programs)
-pango_save_cppflags="$CPPFLAGS"
-AC_TRY_COMPILE([#include <glib.h>],[
-#if !(defined(G_HAVE_ISO_VARARGS) || defined(G_HAVE_GNUC_VARARGS))
-#error "No varargs macro definitions"
+AC_EGREP_CPP(pango_configure_test_yes, [
+#include <glib.h>
+
+#if defined(G_HAVE_ISO_VARARGS) || defined(G_HAVE_GNUC_VARARGS)
+pango_configure_test_yes
#endif
],have_varargs=yes)
AC_MSG_RESULT($have_varargs)
AM_CONDITIONAL(BUILD_OT_TESTS, test $have_varargs = yes)
+CPPFLAGS=$pango_saved_cppflags
#
# Allow building some or all modules included