summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-04-29 22:12:35 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-04-29 22:12:35 +0000
commit36270cf8e27b21c5581859eb99687ca81df2c57e (patch)
tree1ae2232dc57dbde2264b4999ebc8614963aa27fd /configure.in
parent8edb62e4ebf5b272c50961ffdf4e4c23ea70bc6e (diff)
downloadpango-36270cf8e27b21c5581859eb99687ca81df2c57e.tar.gz
Add the fonconfig cflags/libs to FREETYPE_CFLAGS/LIBS. (#111326, Noah
Tue Apr 29 18:02:31 2003 Owen Taylor <otaylor@redhat.com> * configure.in: Add the fonconfig cflags/libs to FREETYPE_CFLAGS/LIBS. (#111326, Noah Levitt) * {pango,tests,examples}/Makefile.am: Remove now unnecessary references to FONTCONFIG_CFLAGS/LIBS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index fd19ae3f..f3ad5b94 100644
--- a/configure.in
+++ b/configure.in
@@ -189,8 +189,6 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
AC_CHECK_LIB(freetype, FT_Get_Next_Char, have_freetype=true, :)
LDFLAGS=$pango_save_ldflags
fi
-AC_SUBST(FREETYPE_LIBS)
-AC_SUBST(FREETYPE_CFLAGS)
#
# Check for fontconfig
@@ -199,11 +197,13 @@ have_fontconfig=false
PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 1.0.1, have_fontconfig=true, :)
-AC_SUBST(FONTCONFIG_LIBS)
-AC_SUBST(FONTCONFIG_CFLAGS)
+FREETYPE_LIBS="$FONTCONFIG_LIBS $FREETYPE_LIBS"
+FREETYPE_CFLAGS="$FONTCONFIG_CFLAGS $FREETYPE_CFLAGS"
+AC_SUBST(FREETYPE_LIBS)
+AC_SUBST(FREETYPE_CFLAGS)
+
AM_CONDITIONAL(HAVE_FREETYPE, $have_freetype && $have_fontconfig)
-
#
# Checks for Xft/XRender
#