summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2002-10-21 23:48:24 +0000
committerTor Lillqvist <tml@src.gnome.org>2002-10-21 23:48:24 +0000
commitefe38161780103a7f01e1f241eca4d02e2039326 (patch)
tree07f9cd08c2af02229fe0cfb32dfee53189f4b889 /configure.in
parentf1da959cfb199c97e45b2bde9a093205e2405247 (diff)
downloadpango-efe38161780103a7f01e1f241eca4d02e2039326.tar.gz
Add --with-usp10 flag to indicate where to find the usp10.h header, for
2002-10-22 Tor Lillqvist <tml@iki.fi> * configure.in: Add --with-usp10 flag to indicate where to find the usp10.h header, for using Uniscribe on Win32. Set USP10_H autoconf variable, HAVE_USP10_H config.h macro and HAVE_USP10_H automake conditional. * acconfig.h: Add HAVE_USP10_H. * pango/pangowin32-private.h (PANGO_WIN32_DEBUGGING): Change semantics of this flag. If defined, also need to set env var PANGO_WIN32_DEBUG to get the copious debugging output. Change PING() macro accordingly. Add variable pango_win32_debug. * pango/pangowin32.c (pango_win32_get_dc): New function. Code factored out from pango_win32_font_class_init() and pango_win32_font_map_class_init(). (pango_win32_get_debug_flag): New function. (pango_win32_render): Handle y offsets, too. Potentially need to call ExtTextOutW several times, one for each run of sequential glyphs with the same y offset. * pango/pangowin32.h: Declare above new functions, in the part only for shaper engine use. * pango/pangowin32.def: Export above new functions. * pango/pangowin32-fontmap.c (pango_win32_font_map_class_init): Call pango_win32_get_dc() as mentioned above. * modules/basic/Makefile.am: If HAVE_USP10_H, let basic-win32.lo depend on usp10.h. * modules/basic/basic-win32.c: If HAVE_USP10_H, and the Uniscribe DLL usp10.dll is present, use Uniscribe. (uniscribe_shape, itemize_shape_and_place, set_up_pango_log_clusters, convert_log_clusters_to_byte_offsets, make_langid, init_uniscribe): New functions. (dump_glyphs_and_log_clusters, lang_name, charset_name): Debugging functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a5c3298a..00b12160 100644
--- a/configure.in
+++ b/configure.in
@@ -429,6 +429,35 @@ AM_CONDITIONAL(INCLUDE_INDIC_XFT,echo $included_modules | egrep '(^|,)indic-xft(
AC_CHECK_FUNCS(flockfile strtok_r)
#
+# Check for the Uniscribe header usp10.h for Win32
+#
+
+AC_ARG_WITH(usp10,
+[ --with-usp10=DIRECTORY where to find the usp10.h header file for Win32
+ (typically the Include directory in the
+ Platform SDK)])
+
+USP10_H=no
+if test "${with_usp10+set}" = set && test "$with_usp10" != no; then
+ AC_MSG_CHECKING([for usp10.h])
+ if test -f "$with_usp10"/usp10.h; then
+ AC_MSG_RESULT(yes)
+ USP10_H="$with_usp10"/usp10.h
+ AC_DEFINE(HAVE_USP10_H)
+ else
+ if test -f "$with_usp10"/include/usp10.h; then
+ AC_MSG_RESULT(yes)
+ USP10_H="$with_usp10"/include/usp10.h
+ AC_DEFINE(HAVE_USP10_H)
+ else
+ AC_MSG_RESULT(no)
+ fi
+ fi
+fi
+AC_SUBST(USP10_H)
+AM_CONDITIONAL(HAVE_USP10_H, test "$USP10_H" != no)
+
+#
# Check for Qt - which we use for building the viewer example, if
# present
#