summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-04-29 22:12:12 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-04-29 22:12:12 +0000
commitf6a418ee9a9b35c1e4eff002853779c269107ad5 (patch)
treed20bfedae249a8d3da1e3ff826352f1d744aad3c /configure.in
parent66d6c38f5f7d7caef0ed4d16edb0b4c6452330bf (diff)
downloadpango-f6a418ee9a9b35c1e4eff002853779c269107ad5.tar.gz
Add the fonconfig cflags/libs to FREETYPE_CFLAGS/LIBS. (#111326, Noah
Tue Apr 29 18:02:31 2003 Owen Taylor <otaylor@redhat.com> * configure.in: Add the fonconfig cflags/libs to FREETYPE_CFLAGS/LIBS. (#111326, Noah Levitt) * {pango,tests,examples}/Makefile.am: Remove now unnecessary references to FONTCONFIG_CFLAGS/LIBS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 2cc16693..077f7beb 100644
--- a/configure.in
+++ b/configure.in
@@ -202,8 +202,6 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
AC_CHECK_LIB(freetype, FT_Get_Next_Char, have_freetype=true, :)
LDFLAGS=$pango_save_ldflags
fi
-AC_SUBST(FREETYPE_LIBS)
-AC_SUBST(FREETYPE_CFLAGS)
#
# Check for fontconfig
@@ -212,11 +210,13 @@ have_fontconfig=false
PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 1.0.1, have_fontconfig=true, :)
-AC_SUBST(FONTCONFIG_LIBS)
-AC_SUBST(FONTCONFIG_CFLAGS)
+FREETYPE_LIBS="$FONTCONFIG_LIBS $FREETYPE_LIBS"
+FREETYPE_CFLAGS="$FONTCONFIG_CFLAGS $FREETYPE_CFLAGS"
+AC_SUBST(FREETYPE_LIBS)
+AC_SUBST(FREETYPE_CFLAGS)
+
AM_CONDITIONAL(HAVE_FREETYPE, $have_freetype && $have_fontconfig)
-
#
# Checks for Xft/XRender
#