summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2004-06-21 16:10:31 +0000
committerOwen Taylor <otaylor@src.gnome.org>2004-06-21 16:10:31 +0000
commit62b4e6b676ae2ef114960529b0a5b79d213820d0 (patch)
tree8a12a666cb475bc13f8d245ca027dfa187ed0a34 /configure.in
parent95059cad33f0ae575af5b8e79c0fddd021c99834 (diff)
downloadpango-62b4e6b676ae2ef114960529b0a5b79d213820d0.tar.gz
Missed commit: add -lm dependency to pkg-config files.
Mon Jun 21 11:47:41 2004 Owen Taylor <otaylor@redhat.com> * configure.in pango.pc.in: Missed commit: add -lm dependency to pkg-config files. * docs/pango-sections.txt: Add PangoMatrix and rotated rendering functions
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 01995269..6d9e8f20 100644
--- a/configure.in
+++ b/configure.in
@@ -514,14 +514,17 @@ if test $enable_explicit_deps = yes ; then
PKGCONFIG_X_LIBS="$X_LIBS $X_EXTRA_LIBS"
PKGCONFIG_XFT_LIBS=$XFT_LIBS
PKGCONFIG_FREETYPE_LIBS=$FREETYPE_LIBS
+ PKGCONFIG_MATH_LIBS=-lm
else
PKGCONFIG_X_LIBS=
PKGCONFIG_XFT_LIBS=
PKGCONFIG_FREETYPE_LIBS=
+ PKGCONFIG_MATH_LIBS=
fi
AC_SUBST(PKGCONFIG_X_LIBS)
AC_SUBST(PKGCONFIG_XFT_LIBS)
AC_SUBST(PKGCONFIG_FREETYPE_LIBS)
+AC_SUBST(PKGCONFIG_MATH_LIBS)
AM_CONDITIONAL(DISABLE_EXPLICIT_DEPS, test $enable_explicit_deps = no)
AC_CONFIG_COMMANDS([pango/module-defs.h],