summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2005-01-09 00:35:07 +0000
committerOwen Taylor <otaylor@src.gnome.org>2005-01-09 00:35:07 +0000
commit5dad21ef6aa140a3dc8cb25eabc11a7b7120b781 (patch)
treed574cb2621e0f9e1f2b490ee936bc386454d932d /configure.in
parent43756415004f72995f6999470136f8081e0b1b41 (diff)
downloadpango-5dad21ef6aa140a3dc8cb25eabc11a7b7120b781.tar.gz
Add a .pc file for pangocairo.
Sat Jan 8 19:28:17 2005 Owen Taylor <otaylor@redhat.com> * Makefile.am configure.in pangocairo.pc.in pangocairo-uninstalled.pc.in: Add a .pc file for pangocairo.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 1c194d57..e502fac2 100644
--- a/configure.in
+++ b/configure.in
@@ -523,21 +523,29 @@ case $enable_explicit_deps in
esac
AC_MSG_RESULT($enable_explicit_deps)
+PKGCONFIG_X_LIBS=
+PKGCONFIG_XFT_LIBS=
+PKGCONFIG_FREETYPE_LIBS=
+PKGCONFIG_MATH_LIBS=
+PKGCONFIG_CAIRO_LIBS=
+
if test $enable_explicit_deps = yes ; then
PKGCONFIG_X_LIBS="$X_LIBS $X_EXTRA_LIBS"
PKGCONFIG_XFT_LIBS=$XFT_LIBS
PKGCONFIG_FREETYPE_LIBS=$FREETYPE_LIBS
PKGCONFIG_MATH_LIBS=-lm
-else
- PKGCONFIG_X_LIBS=
- PKGCONFIG_XFT_LIBS=
- PKGCONFIG_FREETYPE_LIBS=
- PKGCONFIG_MATH_LIBS=
+ PKGCONFIG_CAIRO_LIBS=$FREETYPE_LIBS
+ if $have_cairo_freetype ; then
+ PKGCONFIG_CAIRO_REQUIRES=pangoft2
+ fi
fi
+
AC_SUBST(PKGCONFIG_X_LIBS)
AC_SUBST(PKGCONFIG_XFT_LIBS)
AC_SUBST(PKGCONFIG_FREETYPE_LIBS)
AC_SUBST(PKGCONFIG_MATH_LIBS)
+AC_SUBST(PKGCONFIG_CAIRO_LIBS)
+AC_SUBST(PKGCONFIG_CAIRO_REQUIRES)
AM_CONDITIONAL(DISABLE_EXPLICIT_DEPS, test $enable_explicit_deps = no)
AC_CONFIG_COMMANDS([pango/module-defs.h],
@@ -687,11 +695,13 @@ pangox.pc
pangowin32.pc
pangoft2.pc
pangoxft.pc
+pangocairo.pc
pango-uninstalled.pc
pangox-uninstalled.pc
pangowin32-uninstalled.pc
pangoft2-uninstalled.pc
pangoxft-uninstalled.pc
+pangocairo-uninstalled.pc
pango-zip.sh
])