summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2004-03-03 14:09:45 +0000
committerTor Lillqvist <tml@src.gnome.org>2004-03-03 14:09:45 +0000
commiteaaaec84eb62293526c165fa3ab7b51067298d52 (patch)
tree243cc858a4a436536c816a3432496f6d66817222 /configure.in
parent152e7aa4d4f8a399dbb1e9e06582824586694ec9 (diff)
downloadpango-eaaaec84eb62293526c165fa3ab7b51067298d52.tar.gz
Move check for native Win32 (mingw) a bit earlier. If Win32, disable
2004-03-03 Tor Lillqvist <tml@iki.fi> * configure.in: Move check for native Win32 (mingw) a bit earlier. If Win32, disable static builds (like GLib does).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 24 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 7463ee64..16f322f1 100644
--- a/configure.in
+++ b/configure.in
@@ -78,6 +78,18 @@ AC_SUBST(LT_CURRENT_MINUS_AGE)
dnl ==========================================================================
+AC_MSG_CHECKING([for native Win32])
+case "$host" in
+ *-*-mingw*)
+ pango_os_win32=yes
+ ;;
+ *)
+ pango_os_win32=no
+ ;;
+esac
+AC_MSG_RESULT([$pango_os_win32])
+AM_CONDITIONAL(OS_WIN32, test "$pango_os_win32" = "yes")
+
AC_PROG_CC
dnl
@@ -93,6 +105,18 @@ AC_LANG_RESTORE
AC_LIBTOOL_WIN32_DLL
AM_DISABLE_STATIC
+
+if test "$pango_os_win32" = "yes"; then
+ if test x$enable_static = xyes -o x$enable_static = x; then
+ AC_MSG_WARN([Disabling static library build, must build as DLL on Windows.])
+ enable_static=no
+ fi
+ if test x$enable_shared = xno; then
+ AC_MSG_WARN([Enabling shared library build, must build as DLL on Windows.])
+ fi
+ enable_shared=yes
+fi
+
AM_PROG_LIBTOOL
AC_MSG_CHECKING([for some Win32 platform])
@@ -107,18 +131,6 @@ esac
AC_MSG_RESULT([$pango_platform_win32])
AM_CONDITIONAL(PLATFORM_WIN32, test "$pango_platform_win32" = "yes")
-AC_MSG_CHECKING([for native Win32])
-case "$host" in
- *-*-mingw*)
- pango_os_win32=yes
- ;;
- *)
- pango_os_win32=no
- ;;
-esac
-AC_MSG_RESULT([$pango_os_win32])
-AM_CONDITIONAL(OS_WIN32, test "$pango_os_win32" = "yes")
-
if test "$pango_os_win32" = "yes"; then
AC_CHECK_PROG(ms_librarian, lib.exe, yes, no)
fi