summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-07-21 13:59:36 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-07-21 13:59:36 +0000
commita084f42c0e920e2ac91383b8d98ff54f339d17ac (patch)
treecd2ae4cd9d49439019d4dddda005c02523d26c89 /configure.in
parent1f53784fdae609da25c593d9b99ba830c6513298 (diff)
downloadpango-a084f42c0e920e2ac91383b8d98ff54f339d17ac.tar.gz
Free buffer strings.
Fri Jul 21 09:59:10 2000 Owen Taylor <otaylor@redhat.com> * pango/modules.c (process_module_file): Free buffer strings. * pango/pangox-fontmap.c (pango_x_real_get_coverage_win): Add caching of coverage maps on a persistant subwindow of the root window. This window contains a property for each "lang|xlfd,xlfd" which is the result of pango_coverage_to_bytes. * pango/pango-context.c (pango_context_finalize): Free the font description. * pango/pango-coverage.c (pango_coverage_to/from_bytes): Added functions to covert a PangoCoverage structure too and from a flat block of bytes. * configure.in (X_LIBS): Add a check to detect fribidi being compiled against glib-1.2.x.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a9af7389..28118c49 100644
--- a/configure.in
+++ b/configure.in
@@ -32,6 +32,12 @@ AC_PATH_PROG(FRIBIDI_CONFIG, fribidi-config, no)
if test x$FRIBIDI_CONFIG = xno ; then
AC_MSG_ERROR([*** fribidi-config not found])
fi
+
+if $FRIBID_CONFIG --cflags | grep lib/glib/include ; then
+ AC_MSG_ERROR([*** fribidi appears to be compiled against GLib-1.2.x.
+*** You must compile fribidi with GLib-1.3.1 or better.])
+fi
+
FRIBIDI_CFLAGS="`$FRIBIDI_CONFIG --cflags`"
CFLAGS="$CFLAGS $FRIBIDI_CFLAGS"
FRIBIDI_LIBS="`$FRIBIDI_CONFIG --libs`"
@@ -158,7 +164,7 @@ else
AC_PROG_CXX
fi
-AM_CONDITIONAL(BUILD_QT_TEST, ! test "x$QTDIR" = x)
+AM_CONDITIONAL(BUILD_QT_TEST, test "x$QTDIR" != x)
AC_SUBST(QTDIR)
#