summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-12-20 04:41:36 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-12-20 04:41:36 +0000
commit6ffa65f461d8a78d9190c0d9903a9ecd7273774a (patch)
treef4245e3e7e13771b62224fbdf473edd96d7e7765 /configure.in
parent1a603d00f370167b75a965416080f45824d5b515 (diff)
downloadpango-6ffa65f461d8a78d9190c0d9903a9ecd7273774a.tar.gz
Since Xft may only be available statically without shlib deps, check for
Tue Dec 19 22:47:16 2000 Owen Taylor <otaylor@redhat.com> * configure.in pango-config.in pangoxft.pc.in modules/basic/Makefile.am: Since Xft may only be available statically without shlib deps, check for FreeType libs explicitly and include them when linking, otherwise things won't work. Also, define FREETYPE_CFLAGS from freetype-config --cflags. * modules/basic/basic-xft.c pango/pangoxft-font{,map}.c: Fool Xft into not converting glyph indices by loading the face unencoded then calling FT_Set_Charmap ourselves. * pango/Makefile.am pango/pango-ot.h pango/opentype/* :Add start of opentype handling - most of the actually meat of the code here is the OpenType layout code from FreeType 1 ported to freetype2 and adapted slighlty for our purposes. Also, includes a incomplete OpenType-table-dumping code useful for figuring out what is going on. * pango/pangoxft.h pango/pangoxft-font.h: Add calls for getting FT_Face and PangoOTInfo from PangoXftFont. * modules/arabic/{Makefile.am,arabic-ot.[ch],arabic-xft.c}: Initial support for rendering Arabic with OpenType fonts.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 28 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index a3dd9f5b..c4ac9fc8 100644
--- a/configure.in
+++ b/configure.in
@@ -47,16 +47,37 @@ fi
X_LIBS="$X_LIBS -lX11"
#
+# Checks for FreeType
+#
+FREETYPE_LIBS=
+FREETYPE_CFLAGS=
+have_freetype=false
+AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+if test "x$FREE_CONFIG" != "xno" ; then
+ FREETYPE_CFLAGS=`freetype-config --cflags`
+ FREETYPE_LIBS=`freetype-config --libs`
+
+ AC_CHECK_LIB(freetype, FT_New_Face, have_freetype=true
+ ,:,$FREETYPE_LIBS)
+fi
+AC_SUBST(FREETYPE_LIBS)
+AC_SUBST(FREETYPE_CFLAGS)
+AM_CONDITIONAL(HAVE_FREETYPE, $have_freetype)
+
+#
# Checks for Xft/XRender
#
have_xft=false
XFT_LIBS=""
-AC_CHECK_LIB(Xrender, XRenderFindFormat,
- AC_CHECK_LIB(Xft, XftFontOpen, have_xft=true, :, -lXrender $X_LIBS)
-,:,-lXext $X_LIBS)
-
-if $have_xft = 'true' ; then
- XFT_LIBS="-lXft -lXrender -lXext $X_LIBS"
+XFT_CFLAGS=""
+if test $have_freetype = true ; then
+ AC_CHECK_LIB(Xrender, XRenderFindFormat,
+ AC_CHECK_LIB(Xft, XftFontOpen, have_xft=true, :, -lXrender -lXext $X_LIBS $FREETYPE_LIBS)
+ ,:,-lXext $X_LIBS)
+
+ if $have_xft = 'true' ; then
+ XFT_LIBS="-lXft -lXrender -lXext $X_LIBS $FREETYPE_LIBS"
+ fi
fi
AC_SUBST(XFT_LIBS)
@@ -306,6 +327,7 @@ AC_OUTPUT([
Makefile
pango/Makefile
pango/mini-fribidi/Makefile
+pango/opentype/Makefile
pango/makefile.mingw
pango/pango.rc
pango/pangoft2.rc