summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alla@lysator.liu.se>2001-05-06 15:17:00 +0000
committerAlexander Larsson <alexl@src.gnome.org>2001-05-06 15:17:00 +0000
commita9e84d4f9560fea6c01e9639561a72e2ed246fce (patch)
treec17d983adb1faf0cba39080a932d6fbaceb42c45 /configure.in
parentf10f21057c5fb0626ec16a2e743c68f6f7ee2cab (diff)
downloadpango-a9e84d4f9560fea6c01e9639561a72e2ed246fce.tar.gz
Fix Xft detection by setting CPPFLAGS before trying the Xft/XftFreetyp.h
2001-05-06 Alexander Larsson <alla@lysator.liu.se> * configure.in: Fix Xft detection by setting CPPFLAGS before trying the Xft/XftFreetyp.h header file. Use CPPFLAGS instead of CFLAGS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index e4f85aa2..3648276e 100644
--- a/configure.in
+++ b/configure.in
@@ -78,8 +78,8 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
,:,$FREETYPE_LIBS)
if $have_freetype ; then
- pango_save_cflags="$CFLAGS"
- CFLAGS="$CFLAGS $FREETYPE_CFLAGS"
+ pango_save_cppflags="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $FREETYPE_CFLAGS"
AC_MSG_CHECKING([For sufficiently new FreeType (at least 2.0.1)])
AC_TRY_COMPILE([
@@ -93,7 +93,7 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
AC_MSG_RESULT(no)
fi
- CFLAGS="$pango_save_cflags"
+ CPPFLAGS="$pango_save_cppflags"
fi
fi
AC_SUBST(FREETYPE_LIBS)
@@ -108,6 +108,9 @@ XFT_LIBS=""
XFT_CFLAGS=""
if test $have_x = true ; then
if test $have_freetype = true ; then
+ pango_save_cppflags="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $FREETYPE_CFLAGS"
+
AC_CHECK_LIB(Xrender, XRenderFindFormat,
AC_CHECK_LIB(Xft, XftFontOpen,
AC_CHECK_HEADER(X11/Xft/XftFreetype.h,
@@ -115,6 +118,8 @@ if test $have_x = true ; then
:,-lXrender -lXext $X_LIBS $FREETYPE_LIBS)
,:,-lXext $X_LIBS)
+ CPPFLAGS="$pango_save_cppflags"
+
if $have_xft = 'true' ; then
XFT_LIBS="-lXft -lXrender -lXext $X_LIBS $FREETYPE_LIBS"
fi