summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-25 19:33:58 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-25 19:33:58 +0000
commit1fdf2cb5e708c0a40379bf6f95cfc045289dfa96 (patch)
tree4da6d1ffafc0fae529fc5e9c1587bc88dfa2e723 /configure.in
parent8e3ee8fbef3cb3d62e0709d2eb76d9b04fc9bf70 (diff)
downloadpango-1fdf2cb5e708c0a40379bf6f95cfc045289dfa96.tar.gz
If major.minor of required and available glib versions are the same, add
2006-01-25 Behdad Esfahbod <behdad@gnome.org> * configure.in: If major.minor of required and available glib versions are the same, add -DG_DISABLE_DEPRECATED to GLIB_CFLAGS. (bug #328617) * */Makefile.am: Remove hardcoded -DG_DISABLE_DEPRECATED.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0f62b954..a85186f7 100644
--- a/configure.in
+++ b/configure.in
@@ -340,6 +340,13 @@ PKG_CHECK_MODULES(GLIB, $GLIB_MODULES, :,
# necesary defines for thread-safety.
GLIB_CFLAGS=`$PKG_CONFIG --cflags $GLIB_MODULES gthread-2.0`
+# See if it's safe to turn G_DISABLE_DEPRECATED on.
+GLIB_VERSION_MAJOR_MINOR=`$PKG_CONFIG --modversion glib-2.0 | sed "s/\.@<:@^.@:>@*\$//"`
+GLIB_REQUIRED_VERSION_MAJOR_MINOR=`echo $GLIB_REQUIRED_VERSION | sed "s/\.@<:@^.@:>@*\$//"`
+if test "x$GLIB_VERSION_MAJOR_MINOR" = "x$GLIB_REQUIRED_VERSION_MAJOR_MINOR"; then
+ GLIB_CFLAGS="-DG_DISABLE_DEPRECATED $GLIB_CFLAGS"
+fi
+
#
# The OpenType test programs aren't particularly portable
#