summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2007-01-15 01:57:49 +0000
committerTor Lillqvist <tml@src.gnome.org>2007-01-15 01:57:49 +0000
commitfd7ecbb0203d89f31e9b9b7c10147fa2a3864513 (patch)
tree27f04919af50fc6b05aa9dfb31db2deddebc04b4 /configure.in
parent3f2a3c12565c1a1968a467daeb7ad57800fcda08 (diff)
downloadpango-fd7ecbb0203d89f31e9b9b7c10147fa2a3864513.tar.gz
Don't check for X and don't warn about missing fontconfig on Win32.
2007-01-15 Tor Lillqvist <tml@novell.com> * configure.in: Don't check for X and don't warn about missing fontconfig on Win32. (#392628, Yevgen Muntyan) svn path=/trunk/; revision=2142
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 12 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 775b4ff1..ecbfe86f 100644
--- a/configure.in
+++ b/configure.in
@@ -198,15 +198,18 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
-AC_PATH_XTRA
+have_x=false
+if test "x$pango_os_win32" != xyes; then
+ AC_PATH_XTRA
-if test x$no_x = xyes ; then
- AC_MSG_WARN([X development libraries not found])
- have_x=false
-else
- X_LIBS="$X_LIBS -lX11"
- have_x=true
- AC_DEFINE(HAVE_X, 1, [Have X libraries])
+ if test x$no_x = xyes ; then
+ AC_MSG_WARN([X development libraries not found])
+ have_x=false
+ else
+ X_LIBS="$X_LIBS -lX11"
+ have_x=true
+ AC_DEFINE(HAVE_X, 1, [Have X libraries])
+ fi
fi
AM_CONDITIONAL(HAVE_X, $have_x)
@@ -252,7 +255,7 @@ if $have_fontconfig ; then
AC_DEFINE(HAVE_XFT, 1, [Have Xft library])
fi
fi
-else
+elif test "x$pango_os_win32" != xyes; then
AC_MSG_WARN([No fontconfig found, skipping tests for FreeType and Xft])
fi