summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-02-25 20:06:45 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-02-25 20:06:45 +0000
commitabacca30f29df84d9818cd1395449eff0e4ee171 (patch)
tree4541c04064b0b00416a76d7408d777f6b47b4963 /configure.in
parent3c1ef3b659b2ffdb9613c8d2d330b64dc1fd0963 (diff)
downloadpango-abacca30f29df84d9818cd1395449eff0e4ee171.tar.gz
Add size to the font description structure instead of continually passing
Fri Feb 25 15:04:21 2000 Owen Taylor <otaylor@redhat.com> * libpango/{fonts.c,pango-font.h,pango-context.[ch],pangox.c, pango-attributes.c,examples/viewer.c: Add size to the font description structure instead of continually passing it around as an extra argument. * libpango/pangox.c: Take screen resolution into account when choosing fonts, instead of assumming point == pixel.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 28 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 734ebb47..1ec15e12 100644
--- a/configure.in
+++ b/configure.in
@@ -17,20 +17,40 @@ if test "x$GCC" = "xyes"; then
fi
changequote([,])dnl
+gtk_works=no
AM_PATH_GTK(1.2.0,
- [CFLAGS="$GTK_CFLAGS $CFLAGS"],
- AC_MSG_ERROR(pango requires GTK+ 1.2 or better))
+ [CFLAGS="$GTK_CFLAGS $CFLAGS"; gtk_works=yes],
+ AC_MSG_WARN("Disabling GTK+-based tests"))
+
+AM_CONDITIONAL(BUILD_TESTS, test x$gtk_works = xyes)
AC_CHECK_LIB(fribidi, fribidi_map_range, :,
AC_MSG_ERROR([*** libfribidi not found.]))
+
+# We run glib-config separately to get the gmodule cflags so we
+# can add them to pango-config
+
+AC_PATH_PROG(GLIB_CONFIG, glib-config, no)
+if test x$GLIB_CONFIG = xno ; then
+ AC_MSG_ERROR([*** glib-config not found])
+fi
+GLIB_CFLAGS="`glib-config --cflags gmodule`"
+CFLAGS="$CFLAGS $GLIB_CFLAGS"
+GLIB_LIBS="`glib-config --libs gmodule`"
+AC_SUBST(GLIB_LIBS)
+AC_SUBST(GLIB_CFLAGS)
+
+
AC_PATH_PROG(UNICODE_CONFIG, unicode-config, no)
if test x$UNICODE_CONFIG = xno ; then
AC_MSG_ERROR([*** unicode-config not found])
fi
-CFLAGS="$CFLAGS `unicode-config --cflags`"
+UNICODE_CFLAGS="`unicode-config --cflags`"
+CFLAGS="$CFLAGS $UNICODE_CFLAGS"
UNICODE_LIBS="`unicode-config --libs`"
AC_SUBST(UNICODE_LIBS)
+AC_SUBST(UNICODE_CFLAGS)
AC_CHECK_FUNCS(flockfile)
@@ -52,4 +72,8 @@ docs/Makefile
tools/Makefile
fonts/Makefile
pango.spec
-])
+pango-config
+],[case "$CONFIG_FILES" in
+*pango-config*)chmod +x pango-config;;
+esac])
+