summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSven Neumann <sven@convergence.de>2001-05-02 14:28:15 +0000
committerSven Neumann <neo@src.gnome.org>2001-05-02 14:28:15 +0000
commit071af17799791f216db170770da8bef479fffa7c (patch)
tree057f808d555b4e66751391bd694462c1dfa85d32 /configure.in
parent54dee9a070383e0e36db7f96b53620507d10e3a4 (diff)
downloadpango-071af17799791f216db170770da8bef479fffa7c.tar.gz
do not try to build modules using Xft if X is not available or was
2001-05-02 Sven Neumann <sven@convergence.de> * configure.in: do not try to build modules using Xft if X is not available or was explicitely disabled.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 54893cfb..e9c7523c 100644
--- a/configure.in
+++ b/configure.in
@@ -87,13 +87,15 @@ AM_CONDITIONAL(HAVE_FREETYPE, $have_freetype)
have_xft=false
XFT_LIBS=""
XFT_CFLAGS=""
-if test $have_freetype = true ; then
- AC_CHECK_LIB(Xrender, XRenderFindFormat,
- AC_CHECK_LIB(Xft, XftFontOpen, have_xft=true, :, -lXrender -lXext $X_LIBS $FREETYPE_LIBS)
- ,:,-lXext $X_LIBS)
-
- if $have_xft = 'true' ; then
- XFT_LIBS="-lXft -lXrender -lXext $X_LIBS $FREETYPE_LIBS"
+if test $have_x = true ; then
+ if test $have_freetype = true ; then
+ AC_CHECK_LIB(Xrender, XRenderFindFormat,
+ AC_CHECK_LIB(Xft, XftFontOpen, have_xft=true, :, -lXrender -lXext $X_LIBS $FREETYPE_LIBS)
+ ,:,-lXext $X_LIBS)
+
+ if $have_xft = 'true' ; then
+ XFT_LIBS="-lXft -lXrender -lXext $X_LIBS $FREETYPE_LIBS"
+ fi
fi
fi