summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-03-20 20:36:01 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-03-20 20:36:01 +0000
commit817f21990a8e9e253af102bdaa8046b11b850b73 (patch)
treef860d467380e3e56f76aa616fa1c508e060c56ea /configure.in
parentd1ac642976eebe752aa9825d50b049b2b7754491 (diff)
downloadpango-817f21990a8e9e253af102bdaa8046b11b850b73.tar.gz
Error out if no backends found. (#74880)
Wed Mar 20 15:22:54 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Error out if no backends found. (#74880)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c0d7e855..76735c63 100644
--- a/configure.in
+++ b/configure.in
@@ -244,6 +244,17 @@ AC_SUBST(WIN32_LIBS)
AM_CONDITIONAL(HAVE_WIN32, $have_win32)
#
+# We must have some backend defined, in order for the pango-querymodules
+# rule in pango/Makefile.am to work correctly. If you are up to writing
+# a new Pango backend outside of Pango, you are up to sending the necessary
+# patch to fix that rule. :-)
+#
+if $HAVE_FREETYPE || $HAVE_X || $HAVE_XFT || $HAVE_WIN32 ; then : ; else
+ AC_MSG_ERROR([*** Didn't find any of FreeType, X11, or Win32.
+*** Must have at least one backend to build Pango.])
+fi
+
+#
# Checks for GLib
#
GLIB_REQUIRED_VERSION=2.0.0