summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2005-02-03 20:23:19 +0000
committerOwen Taylor <otaylor@src.gnome.org>2005-02-03 20:23:19 +0000
commit7782bba2c87b79bff8fa4e62ed84b95b74574617 (patch)
tree79d989164f0c8ab27e825ef98ef3c47a14c39228 /configure.in
parentc7e3de50fdaec8436fd78b229bbdf04c6c9271d3 (diff)
downloadpango-7782bba2c87b79bff8fa4e62ed84b95b74574617.tar.gz
Open the file with mode "wb", include cairo-png.h.
2005-02-03 Owen Taylor <otaylor@redhat.com> * examples/cairosimple.c: Open the file with mode "wb", include cairo-png.h. * examples/xftview.c examples/cairoview.c: Set WM_NORMAL_HINTS to avoid triggering a metacity bug. * examples/cairoview.c: Include cairo-xlib.h. * configure.in: Add checks for the Win32 Cairo backend. (not committing the code yet). * examples/Makefile.am pango/Makefile.am: add CAIRO_CFLAGS. * pango/pangocairo-fc.h pango/pangocairo-fcfont.c pango/pangocairo-fcfontmap.c pango/pangofc-fontmap.[ch]: Rework Cairo/Fontconfig backend to use the current Cairo API. Make some PangoFcFontMap changes to enable that. * pango/pango/pangocairo-private.h pango/pangocairo-render.c: Update for cairo_font_t changes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in53
1 files changed, 29 insertions, 24 deletions
diff --git a/configure.in b/configure.in
index e502fac2..d5adf9e7 100644
--- a/configure.in
+++ b/configure.in
@@ -248,30 +248,6 @@ AM_CONDITIONAL(HAVE_FREETYPE, $have_freetype)
AM_CONDITIONAL(HAVE_XFT, $have_xft)
#
-# Checks for Cairo
-#
-have_cairo=false
-have_cairo_freetype=false
-
-PKG_CHECK_MODULES(CAIRO, cairo >= 0.2.0, have_cairo=true, :)
-
-if $have_cairo ; then
- pango_save_ldflags=$LDFLAGS
- LDFLAGS="$LDFLAGS $CAIRO_LIBS"
- AC_CHECK_LIB(cairo, cairo_ft_font_face, have_cairo_freetype=true, :)
- LDFLAGS=$pango_save_ldflags
- if $have_cairo_freetype ; then
- AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo uses FreeType for fonts])
- else
- AC_MSG_WARN([Disabling Cairo support, no known font system])
- have_cairo=false
- fi
-fi
-
-AM_CONDITIONAL(HAVE_CAIRO, $have_cairo)
-AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype)
-
-#
# Checks for Win32 GDI
#
have_win32=false
@@ -292,6 +268,35 @@ AC_SUBST(WIN32_LIBS)
AM_CONDITIONAL(HAVE_WIN32, $have_win32)
#
+# Checks for Cairo
+#
+have_cairo=false
+have_cairo_freetype=false
+have_cairo_win32=false
+
+PKG_CHECK_MODULES(CAIRO, cairo >= 0.2.0, have_cairo=true, :)
+
+if $have_cairo ; then
+ pango_save_ldflags=$LDFLAGS
+ LDFLAGS="$LDFLAGS $CAIRO_LIBS"
+ AC_CHECK_LIB(cairo, cairo_win32_font_select_font, have_cairo_win32=true, :)
+ LDFLAGS=$pango_save_ldflags
+ if $have_cairo_win32 && $have_win32; then
+ AC_DEFINE(HAVE_CAIRO_WIN32, 1, [Whether Cairo uses the Win32 GDI for fonts])
+ else
+ AC_CHECK_LIB(cairo, cairo_ft_font_lock_face, have_cairo_freetype=true, :)
+ LDFLAGS=$pango_save_ldflags
+ if $have_cairo_freetype && $have_freetype ; then
+ AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo uses FreeType for fonts])
+ fi
+ fi
+fi
+
+AM_CONDITIONAL(HAVE_CAIRO, $have_cairo)
+AM_CONDITIONAL(HAVE_CAIRO_WIN32, $have_cairo_win32 && $have_win32)
+AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype && $have_freetype)
+
+#
# We must have some backend defined, in order for the pango-querymodules
# rule in pango/Makefile.am to work correctly. If you are up to writing
# a new Pango backend outside of Pango, you are up to sending the necessary