summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-28 17:05:32 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-28 17:05:32 +0000
commit3a4d01fcb6f038d49212dad11eb481e3a94d3ca2 (patch)
tree352aac7439d2ad9311d69e8ae9a59ee52a1c29b1 /configure.in
parent53c80ee556aeb6840435850ffa2a5aefec4509ea (diff)
downloadpango-3a4d01fcb6f038d49212dad11eb481e3a94d3ca2.tar.gz
Use AC_HELP_STRING everywhere. Bump required version to 2.56.
2006-01-28 Behdad Esfahbod <behdad@gnome.org> * configure.in: Use AC_HELP_STRING everywhere. Bump required version to 2.56. * doc/tmpl/pango-renderer.sgml (PANGO_TYPE_RENDER_PART): Document it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 12 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index a85186f7..c36d0403 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to create configure.
-AC_PREREQ(2.54)
+AC_PREREQ(2.56)
dnl ==========================================================================
dnl Versioning
@@ -158,7 +158,8 @@ m4_define([debug_default],
AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug=@<:@no/minimum/yes@:>@],
- [turn on debugging @<:@default=debug_default()@:>@]),,
+ [turn on debugging @<:@default=debug_default()@:>@]),
+ ,
enable_debug=debug_default())
if test "x$enable_debug" = "xyes"; then
@@ -386,13 +387,9 @@ all_modules="$arabic_modules,$basic_modules,$hangul_modules,$hebrew_modules,$ind
#
AC_MSG_CHECKING(modules to link statically)
-dnl I would use AC_HELP_STRING here, but due to some bugs in m4_text_wrap,
-dnl it interprets the commas incorrectly ...
-dnl AC_HELP_STRING([--with-included-modules=MODULE1 MODULE2 ...],
-dnl [build the given modules into Pango])
AC_ARG_WITH(included_modules,
-[ --with-included-modules=MODULE1,MODULE2,...
- build the given modules into Pango @<:@default=no@:>@])
+ AC_HELP_STRING([--with-included-modules=no/yes/MODULE1 MODULE2 ...],
+ [build the given modules included @<:@default=no@:>@]))
included_modules=""
case x$with_included_modules in
@@ -408,13 +405,9 @@ AM_CONDITIONAL(HAVE_INCLUDED_MODULES, test "x$included_modules" != x)
#
AC_MSG_CHECKING(dynamic modules to build)
-dnl I would use AC_HELP_STRING here, but due to some bugs in m4_text_wrap,
-dnl it interprets the commas incorrectly ...
-dnl AC_HELP_STRING([--with-dynamic-modules=MODULE1 MODULE2 ...],
-dnl [build the given dynamic modules])
AC_ARG_WITH(dynamic_modules,
-[ --with-dynamic-modules=MODULE1,MODULE2,...
- build the given dynamic modules @<:@default=yes@:>@])
+ AC_HELP_STRING([--with-dynamic-modules=no/yes/MODULE1 MODULE2 ...],
+ [build the given dynamic modules @<:@default=yes@:>@]))
dynamic_modules=""
case x$with_dynamic_modules in
@@ -528,8 +521,9 @@ fi
GTK_DOC_CHECK([1.0])
AC_ARG_ENABLE(man,
- [AC_HELP_STRING([--enable-man],
- [regenerate man pages from Docbook [default=no]])],enable_man=yes,
+ AC_HELP_STRING([--enable-man],
+ [regenerate man pages from Docbook @<:@default=no@:>@]),
+ enable_man=yes,
enable_man=no)
if test "x$enable_man" != xno ; then
@@ -590,7 +584,8 @@ dnl * See whether to include shared library dependencies *
dnl ******************************************************
AC_ARG_ENABLE(explicit-deps,
- [ --enable-explicit-deps=[yes/no/auto] use explicit dependencies in .pc files [default=auto]],
+ AC_HELP_STRING([--enable-explicit-deps=@<:@no/auto/yes@:>@],
+ [use explicit dependencies in .pc files @<:@default=auto@:>@]),
enable_explicit_deps="$enableval",
enable_explicit_deps=auto)