summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-07-24 19:29:30 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-07-24 19:29:30 +0000
commit635ab57f33530f586a861309d25f7628caa77b5d (patch)
tree7e3867cfb16ba24356f95dbd079aa26f1cdaaef6 /configure.in
parentbf9223a0e92ce4323f6e7840df4d9b08f35268a6 (diff)
downloadpango-635ab57f33530f586a861309d25f7628caa77b5d.tar.gz
Remove Qt-based example; it was only testing the obsolete pango-x backend,
Thu Jul 24 15:09:22 2003 Owen Taylor <otaylor@redhat.com> * configure.in examples/Makefile.am examples/viewer-qt.{cc,h}: Remove Qt-based example; it was only testing the obsolete pango-x backend, and was causing more problems for people trying to configure Pango then it was worth. * examples/viewer.c: Remove obsolete test case from CVS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in69
1 files changed, 0 insertions, 69 deletions
diff --git a/configure.in b/configure.in
index bba72c71..ecf4c5cc 100644
--- a/configure.in
+++ b/configure.in
@@ -463,75 +463,6 @@ fi
AC_SUBST(USP10_H)
AM_CONDITIONAL(HAVE_USP10_H, test "$USP10_H" != no)
-#
-# Check for Qt - which we use for building the viewer example, if
-# present
-#
-
-AC_ARG_WITH(qt, [ --with-qt=DIR location where Qt is installed],,with_qt=yes)
-
-if test "$CXX" != "" ; then
- AC_MSG_CHECKING(For Qt location)
-
- if test "x$with_qt" = xyes ; then
- # Search for Qt in a common location. The ls -r is an attempt to find the newest
- if test "x$QTDIR" != x ; then
- if test -x $QTDIR/bin/moc ; then : ; else
- QTDIR=
- fi
- else
- dirs=`cd /usr/lib && ls -d -r qt* 2>/dev/null`
- for dir in $dirs ; do
- case $dir in
- qt2*|qt-2*|qt3*|qt-3*)
- if test -x /usr/lib/$dir/bin/moc ; then
- QTDIR=/usr/lib/$dir
- break
- fi
- ;;
- esac
- done
- fi
- else
- if test "x$with_qt" != xno ; then
- if test -x $with_qt/bin/moc ; then
- QTDIR=$with_qt
- fi
- else
- QTDIR=""
- fi
- fi
-
- if test "x$QTDIR" = x ; then
- AC_MSG_RESULT(none)
- else
- AC_MSG_RESULT($QTDIR)
- fi
-else
- QTDIR=""
-fi
-
-if test x"$QTDIR" != "x" ; then
- AC_MSG_CHECKING(For working Qt)
-
- pango_save_libs="$LIBS"
- pango_save_cppflags="$CPPFLAGS"
- LIBS="-L$QTDIR/lib -lqt $LIBS"
- CPPFLAGS="-I $QTDIR/include"
- AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- AC_TRY_LINK([#include <qapplication.h>],
- [QApplication a ();],
- [AC_MSG_RESULT(yes)],
- [QTDIR=""; AC_MSG_RESULT(no)])
- AC_LANG_RESTORE
- LIBS="$pango_save_libs"
- CPPFLAGS="$pango_save_cppflags"
-fi
-
-AM_CONDITIONAL(BUILD_QT_TEST, test "x$QTDIR" != x)
-AC_SUBST(QTDIR)
-
dnl **************************
dnl *** Checks for gtk-doc ***
dnl **************************