summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-02-17 20:52:33 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-02-17 20:52:33 +0000
commitc41f4d092ad5f2bd837b29e739491107cda41a82 (patch)
treefd97b9f7b84683546dbfd827b503e5c1872c9628 /configure.in
parent4f41b4f9982e639cadf0a193e228af9d45aba44c (diff)
downloadpango-c41f4d092ad5f2bd837b29e739491107cda41a82.tar.gz
Add an --enable-debug configure argument defaulting to 'yes' for unstable
Mon Feb 17 13:06:39 2003 Owen Taylor <otaylor@redhat.com> * configure.in **/Makefile.am: Add an --enable-debug configure argument defaulting to 'yes' for unstable releases and 'minimum' for stable releases. For minimum, -DG_DISABLE_CAST_CHECKS. * pango/pangofc-fontmap.cI pango/pangoft2-fontmap.c pango/pangoxft-fontmap.c: Add caching of fontsets (#104495, initial patch and review by Soeren Sandmann) * pango/pangofc-fontmap.cI pango/pangoft2-fontmap.c pango/pangoxft-fontmap.c pango/pangoft2-private.h pango/pangoxft-private.h: Remove cache of recently freed fonts; not necessary now that we cache fontsets. * pango/pangofc-fontmap.cI (pango_fc_pattern_set_free): Rename from pango_fc_font_set_free to reflect what it actually does. * pango/pangofc-fontmap.cI pango/pangoft-fontmap.c pango/pangoxft-fontmap.c: Combine clear-the-cache functions; we didn't need separate clear-the-font-cache and clear-the-pattern-cache functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 32 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 65ef7692..a0dec115 100644
--- a/configure.in
+++ b/configure.in
@@ -14,10 +14,20 @@ dnl if any functions have been added, set PANGO_INTERFACE_AGE to 0.
dnl if backwards compatibility has been broken,
dnl set PANGO_BINARY_AGE _and_ PANGO_INTERFACE_AGE to 0.
+dnl
+dnl We do the version number components as m4 macros
+dnl so that we can base configure --help output off
+dnl of them.
+dnl
+
dnl The triplet
-PANGO_MAJOR_VERSION=1
-PANGO_MINOR_VERSION=2
-PANGO_MICRO_VERSION=1
+m4_define([pango_major_version],1)
+m4_define([pango_minor_version],2)
+m4_define([pango_micro_version],1)
+
+PANGO_MAJOR_VERSION=pango_major_version()
+PANGO_MINOR_VERSION=pango_minor_version()
+PANGO_MICRO_VERSION=pango_micro_version()
PANGO_VERSION=$PANGO_MAJOR_VERSION.$PANGO_MINOR_VERSION.$PANGO_MICRO_VERSION
dnl The X.Y in -lpango-X.Y line. This is expected to stay 1.0 until Pango 2.
@@ -116,6 +126,25 @@ if test "x$GCC" = "xyes"; then
fi
changequote([,])dnl
+dnl declare --enable-* args and collect ac_help strings
+
+m4_define([debug_default],dnl
+m4_if(m4_bregexp(pango_minor_version(),[[13579]]),-1,minimum,yes))
+
+AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging @<:@default=]debug_default()[@:>@],,enable_debug=debug_default())
+
+if test "x$enable_debug" = "xyes"; then
+ PANGO_DEBUG_FLAGS="-DPANGO_ENABLE_DEBUG"
+else
+ PANGO_DEBUG_FLAGS="-DG_DISABLE_CAST_CHECKS"
+
+ if test "x$enable_debug" = "xno"; then
+ PANGO_DEBUG_FLAGS="$GLIB_DEBUG_FLAGS -DG_DISABLE_ASSERT -DG_DISABLE_CHECKS"
+ fi
+fi
+
+AC_SUBST(PANGO_DEBUG_FLAGS)
+
AC_ARG_ENABLE(rebuilds, [ --disable-rebuilds disable all source autogeneration rules],,enable_rebuilds=yes)
AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)