summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <maclas@gmx.de>2003-06-17 20:31:22 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2003-06-17 20:31:22 +0000
commitc426f10d3b7157c5e1b290192e2abf7e902bc2b3 (patch)
tree83b83cd2ea2dbac72647b44b1e7e70008773f681 /configure.in
parent4e4877a6069d04ec7473d74b406518b0b4657df1 (diff)
downloadpango-c426f10d3b7157c5e1b290192e2abf7e902bc2b3.tar.gz
Add rule to regenerate man pages from Docbook. (man_MANS): Add
2003-06-17 Matthias Clasen <maclas@gmx.de> * docs/Makefile.am: Add rule to regenerate man pages from Docbook. (man_MANS): Add pango-querymodules.1. (content_files): Add pangoe-querymodules.xml. * docs/pango-querymodules.xml: New refentry. * docs/pango-querymodules.1: Man page generated from the .xml source. * docs/pango-docs.sgml: Include pango-querymodules.xml. * acinclude.m4 (JH_PATH_XML_CATALOG, JH_CHECK_XML_CATALOG): New macros to check for XML catalog contents and path, borrowed from gtk-doc. * configure.in: New option --enable-man to enable regeneration of man pages from Docbook, if the necessary tools are found.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a3b6cf9a..404adbf2 100644
--- a/configure.in
+++ b/configure.in
@@ -563,6 +563,26 @@ dnl **************************
GTK_DOC_CHECK([1.0])
+AC_ARG_ENABLE(man,
+ [AC_HELP_STRING([--enable-man],
+ [regenerate man pages from Docbook [default=no]])],enable_man=yes,
+ enable_man=no)
+
+dnl
+dnl Check for xsltproc
+dnl
+AC_PATH_PROG([XSLTPROC], [xsltproc])
+if test -z "$XSLTPROC"; then
+ enable_man=no
+fi
+
+dnl check for DocBook DTD and stylesheets in the local catalog.
+JH_CHECK_XML_CATALOG([-//OASIS//DTD DocBook XML V4.1.2//EN],
+ [DocBook XML DTD V4.1.2],,enable_man=no)
+JH_CHECK_XML_CATALOG([http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
+ [DocBook XSL Stylesheets],,enable_man=no)
+AM_CONDITIONAL(ENABLE_MAN, test x$enable_man != xno)
+
dnl ********************************************************
dnl * See whether we need to load our modules as .la files *
dnl ********************************************************