summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-07-24 20:02:08 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-07-24 20:02:08 +0000
commite5c7056c3839616f1087d722ac03c1ee7c7d636f (patch)
tree55e666b3ae373650db4b5f354fb36050aeb87968 /configure.in
parentebbf349278d1584843ddacce3e397f110b851135 (diff)
downloadpango-e5c7056c3839616f1087d722ac03c1ee7c7d636f.tar.gz
Clean up checks for usp10.h
Thu Jul 24 15:55:31 2003 Owen Taylor <otaylor@redhat.com> * configure.in: Clean up checks for usp10.h * configure.in: Remove configure option for XftConfig location. * acconfig.h: Remove, not needed with autoconf-2.5x. (#114916, Tony Graham)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 9 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 099194a1..62ad011a 100644
--- a/configure.in
+++ b/configure.in
@@ -183,7 +183,7 @@ if test x$no_x = xyes ; then
else
X_LIBS="$X_LIBS -lX11"
have_x=true
- AC_DEFINE(HAVE_X)
+ AC_DEFINE(HAVE_X, 1, [Have X libraries])
fi
AM_CONDITIONAL(HAVE_X, $have_x)
@@ -283,17 +283,6 @@ AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)
#
-# Allow setting a default path for XftConfig
-#
-AC_ARG_WITH(xftconfig-dir,
- [AC_HELP_STRING([--with-xftconfig-dir=PATH],
- [path to system XftConfig file for minixft])])
-
-if test "x$with_xftconfig_dir" != "x"; then
- AC_DEFINE_UNQUOTED(MINI_XFTCONFIG_DIR, "$with_xftconfig_dir")
-fi
-
-#
# The OpenType test programs aren't particularly portable
#
have_varargs=no
@@ -431,17 +420,15 @@ USP10_H=no
if test "${with_usp10+set}" = set && test "$with_usp10" != no; then
AC_MSG_CHECKING([for usp10.h])
if test -f "$with_usp10"/usp10.h; then
- AC_MSG_RESULT(yes)
USP10_H="$with_usp10"/usp10.h
- AC_DEFINE(HAVE_USP10_H)
+ elif test -f "$with_usp10"/include/usp10.h; then
+ USP10_H="$with_usp10"/include/usp10.h
+ fi
+ if test "x$USP10_H" != "xno" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_USP10_H, 1, [Have the usp10.h header file for Win32])
else
- if test -f "$with_usp10"/include/usp10.h; then
- AC_MSG_RESULT(yes)
- USP10_H="$with_usp10"/include/usp10.h
- AC_DEFINE(HAVE_USP10_H)
- else
- AC_MSG_RESULT(no)
- fi
+ AC_MSG_RESULT(no)
fi
fi
AC_SUBST(USP10_H)
@@ -669,7 +656,7 @@ EOTEXT
AC_HEADER_DIRENT
-AC_CHECK_HEADER(unistd.h, AC_DEFINE(HAVE_UNISTD_H))
+AC_CHECK_HEADERS(unistd.h)
# Honor aclocal flags
ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"