summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2005-03-01 20:02:33 +0000
committerOwen Taylor <otaylor@src.gnome.org>2005-03-01 20:02:33 +0000
commit97d609b5bfea75944ef1c4b65ea1fd4048c4b5cd (patch)
treeb18efbe889f3e23f83d7ce34440196f46e4737b4 /configure.in
parent5262e5f1e3349a78468d2f5b05d83a1d3487671d (diff)
downloadpango-97d609b5bfea75944ef1c4b65ea1fd4048c4b5cd.tar.gz
Use PKG_CHECK_MODULES not AM_PATH_GLIB_2_0 to avoid a problem where older
2005-03-01 Owen Taylor <otaylor@redhat.com> * configure.in: Use PKG_CHECK_MODULES not AM_PATH_GLIB_2_0 to avoid a problem where older verisons of AM_PATH_GLIB_2_0 silently ignored gmodule-no-export causing mysterious build failures. (#161786) * pango/Makefile.am (DISTCLEANFILES): Move some configure.in output files from CLEANFILES to DISTCLEANFILES.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 5f283583..bd6d3053 100644
--- a/configure.in
+++ b/configure.in
@@ -282,17 +282,16 @@ fi
# Checks for GLib
#
GLIB_REQUIRED_VERSION=2.5.7
+GLIB_MODULES="glib-2.0 >= $GLIB_REQUIRED_VERSION gobject-2.0 gmodule-no-export-2.0"
-AM_PATH_GLIB_2_0($GLIB_REQUIRED_VERSION, :,
+PKG_CHECK_MODULES(GLIB, $GLIB_MODULES, :,
AC_MSG_ERROR([
*** Glib $GLIB_REQUIRED_VERSION or better is required. The latest version of
-*** Glib is always available from ftp://ftp.gtk.org/.]),
- gobject gmodule-no-export)
+*** Glib is always available from ftp://ftp.gtk.org/.]))
-GLIB_CFLAGS=`$PKG_CONFIG --cflags gmodule-no-export-2.0 gthread-2.0`
-
-AC_SUBST(GLIB_LIBS)
-AC_SUBST(GLIB_CFLAGS)
+# Add in gthread-2.0 to CFLAGS but not to LIBS so we get any
+# necesary defines for thread-safety.
+GLIB_CFLAGS=`$PKG_CONFIG --cflags $GLIB_MODULES gthread-2.0`
#
# The OpenType test programs aren't particularly portable