summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2004-03-03 21:20:59 +0000
committerOwen Taylor <otaylor@src.gnome.org>2004-03-03 21:20:59 +0000
commit97493ff91793542b28f915cf0243598e4c4c03bf (patch)
treea25d2e749ab5394b9e5a04fe03ca63fb5d516e87 /configure.in
parenteb1f299dd93e42adaffa9fe35138afe6840abbc6 (diff)
downloadpango-97493ff91793542b28f915cf0243598e4c4c03bf.tar.gz
Strip out the "export-dynamic" libtool option from library link lines.
Wed Mar 3 16:00:10 2004 Owen Taylor <otaylor@redhat.com> * configure.in: Strip out the "export-dynamic" libtool option from library link lines. (#124687, James Henstridge)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 16f322f1..29b38d7a 100644
--- a/configure.in
+++ b/configure.in
@@ -294,6 +294,23 @@ GLIB_CFLAGS=`$PKG_CONFIG --cflags gmodule-2.0 gthread-2.0`
AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)
+################################################################
+# Strip -export-dynamic from the link line
+################################################################
+
+#
+# pkg-config --libs gmodule includes the "export_dynamic" flag,
+# but this flag is only meaningful for executables. For libraries
+# the effect is undefined; what it causes on Linux is that the
+# export list from -export-symbols-regex is ignored and everything
+# is exported
+#
+export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+if test -n "$export_dynamic"; then
+ GLIB_LIBS=`echo $GLIB_LIBS | sed -e "s/$export_dynamic//"`
+fi
+
+
#
# The OpenType test programs aren't particularly portable
#