summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2004-02-13 15:29:33 +0000
committerOwen Taylor <otaylor@src.gnome.org>2004-02-13 15:29:33 +0000
commita036dc6bbf67584d8e7ae8ac0a72b7c922977a7a (patch)
tree8a8e7362b4453414039cfce7d4eae2348a850f57 /configure.in
parent7ff50a2173cb8fdf59472c24cde9883dd0d862bf (diff)
downloadpango-a036dc6bbf67584d8e7ae8ac0a72b7c922977a7a.tar.gz
Skip the xslt and stylesheet checks unless --enable-man is specified.
Fri Feb 13 10:19:16 2004 Owen Taylor <otaylor@redhat.com> * configure.in: Skip the xslt and stylesheet checks unless --enable-man is specified. (#134133, Julio M. Merino Vidal)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 16 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index ca6a0c98..76ddbe58 100644
--- a/configure.in
+++ b/configure.in
@@ -422,19 +422,24 @@ AC_ARG_ENABLE(man,
[regenerate man pages from Docbook [default=no]])],enable_man=yes,
enable_man=no)
-dnl
-dnl Check for xsltproc
-dnl
-AC_PATH_PROG([XSLTPROC], [xsltproc])
-if test -z "$XSLTPROC"; then
- enable_man=no
+if test "x$enable_man" != xno ; then
+ dnl
+ dnl Check for xsltproc
+ dnl
+ AC_PATH_PROG([XSLTPROC], [xsltproc])
+ if test -z "$XSLTPROC"; then
+ enable_man=no
+ fi
+fi
+
+if test "x$enable_man" != xno ; then
+ dnl check for DocBook DTD and stylesheets in the local catalog.
+ JH_CHECK_XML_CATALOG([-//OASIS//DTD DocBook XML V4.1.2//EN],
+ [DocBook XML DTD V4.1.2],,enable_man=no)
+ JH_CHECK_XML_CATALOG([http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
+ [DocBook XSL Stylesheets],,enable_man=no)
fi
-dnl check for DocBook DTD and stylesheets in the local catalog.
-JH_CHECK_XML_CATALOG([-//OASIS//DTD DocBook XML V4.1.2//EN],
- [DocBook XML DTD V4.1.2],,enable_man=no)
-JH_CHECK_XML_CATALOG([http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
- [DocBook XSL Stylesheets],,enable_man=no)
AM_CONDITIONAL(ENABLE_MAN, test x$enable_man != xno)
dnl ********************************************************