summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-07-24 19:29:20 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-07-24 19:29:20 +0000
commitfd8ee1c032d688a9d87b9355fe3ef1b01a9f95f5 (patch)
tree9b85a241b084a90c9937d26772a2d638b7f7b848 /configure.in
parent4a52f3061f0b2b435f055caba1df400158a42c16 (diff)
downloadpango-fd8ee1c032d688a9d87b9355fe3ef1b01a9f95f5.tar.gz
Remove Qt-based example; it was only testing the obsolete pango-x backend,
Thu Jul 24 15:09:22 2003 Owen Taylor <otaylor@redhat.com> * configure.in examples/Makefile.am examples/viewer-qt.{cc,h}: Remove Qt-based example; it was only testing the obsolete pango-x backend, and was causing more problems for people trying to configure Pango then it was worth. * examples/viewer.c: Remove obsolete test case from CVS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in72
1 files changed, 0 insertions, 72 deletions
diff --git a/configure.in b/configure.in
index 404adbf2..10fe1abe 100644
--- a/configure.in
+++ b/configure.in
@@ -485,78 +485,6 @@ fi
AC_SUBST(USP10_H)
AM_CONDITIONAL(HAVE_USP10_H, test "$USP10_H" != no)
-#
-# Check for Qt - which we use for building the viewer example, if
-# present
-#
-
-AC_ARG_WITH(qt,
- [AC_HELP_STRING([--with-qt=DIR],
- [location where Qt is installed])],,
- [with_qt=yes])
-
-if test "$CXX" != "" ; then
- AC_MSG_CHECKING(For Qt location)
-
- if test "x$with_qt" = xyes ; then
- # Search for Qt in a common location. The ls -r is an attempt to find the newest
- if test "x$QTDIR" != x ; then
- if test -x $QTDIR/bin/moc ; then : ; else
- QTDIR=
- fi
- else
- dirs=`cd /usr/lib && ls -d -r qt* 2>/dev/null`
- for dir in $dirs ; do
- case $dir in
- qt2*|qt-2*|qt3*|qt-3*)
- if test -x /usr/lib/$dir/bin/moc ; then
- QTDIR=/usr/lib/$dir
- break
- fi
- ;;
- esac
- done
- fi
- else
- if test "x$with_qt" != xno ; then
- if test -x $with_qt/bin/moc ; then
- QTDIR=$with_qt
- fi
- else
- QTDIR=""
- fi
- fi
-
- if test "x$QTDIR" = x ; then
- AC_MSG_RESULT(none)
- else
- AC_MSG_RESULT($QTDIR)
- fi
-else
- QTDIR=""
-fi
-
-if test x"$QTDIR" != "x" ; then
- AC_MSG_CHECKING(For working Qt)
-
- pango_save_libs="$LIBS"
- pango_save_cppflags="$CPPFLAGS"
- LIBS="-L$QTDIR/lib -lqt $LIBS"
- CPPFLAGS="-I $QTDIR/include"
- AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- AC_TRY_LINK([#include <qapplication.h>],
- [QApplication a ();],
- [AC_MSG_RESULT(yes)],
- [QTDIR=""; AC_MSG_RESULT(no)])
- AC_LANG_RESTORE
- LIBS="$pango_save_libs"
- CPPFLAGS="$pango_save_cppflags"
-fi
-
-AM_CONDITIONAL(BUILD_QT_TEST, test "x$QTDIR" != x)
-AC_SUBST(QTDIR)
-
dnl **************************
dnl *** Checks for gtk-doc ***
dnl **************************