summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2010-09-21 15:47:17 -0400
committerBehdad Esfahbod <behdad@behdad.org>2010-09-21 15:49:07 -0400
commit64ada662476f5b5506a9a455f4c39242ab51ff38 (patch)
treee823ef001fb95198ba0fea2944db8334daef4942 /configure.in
parente008ca8f198965b55fc4ef297b4d31902b5afc36 (diff)
parent254f42980e272f0560b28d466c2b65a1748b1132 (diff)
downloadpango-64ada662476f5b5506a9a455f4c39242ab51ff38.tar.gz
Merge branch 'master' into harfbuzz-ng-external
Conflicts: pango/Makefile.am pango/pango-ot-buffer.c pango/pango-ot-info.c Removed: pango/opentype/Makefile.am pango/opentype/hb-blob.c pango/opentype/hb-open-file-private.hh pango/opentype/hb-open-type-private.hh pango/opentype/hb-ot-layout-common-private.hh pango/opentype/hb-ot-layout-gdef-private.hh pango/opentype/hb-ot-layout-gpos-private.hh pango/opentype/hb-ot-layout-gsub-private.hh pango/opentype/hb-ot-layout-gsubgpos-private.hh pango/opentype/hb-ot-layout.cc pango/opentype/hb-ot-layout.h pango/opentype/hb-private.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in52
1 files changed, 11 insertions, 41 deletions
diff --git a/configure.in b/configure.in
index b3fb74b4..8445bc2c 100644
--- a/configure.in
+++ b/configure.in
@@ -21,16 +21,13 @@ dnl
dnl The triplet
m4_define([pango_version_major], [1])
-m4_define([pango_version_minor], [26])
+m4_define([pango_version_minor], [29])
m4_define([pango_version_micro], [0])
m4_define([pango_version],
[pango_version_major.pango_version_minor.pango_version_micro])
dnl The X.Y in -lpango-X.Y line. This is expected to stay 1.0 until Pango 2.
m4_define([pango_api_version], [1.0])
-dnl Number of releases since we've added interfaces
-dnl XXX For 1.25 release simply remove it and make it automatic.
-m4_define([pango_interface_age], [0])
m4_if(m4_eval(pango_version_minor % 2), [1],
[
dnl for unstable releases
@@ -228,19 +225,6 @@ AC_ARG_ENABLE(rebuilds,
AM_CONDITIONAL(CROSS_COMPILING, [test $cross_compiling = yes])
-# define a MAINT-like variable REBUILD which is set if Perl
-# is found, so autogenerated sources can be rebuilt
-
-AC_CHECK_PROGS(PERL, perl5 perl)
-
-REBUILD=\#
-if test "x$enable_rebuilds" = "xyes" && \
- test -n "$PERL" && \
- $PERL -e 'exit !($] >= 5.002)' > /dev/null 2>&1 ; then
- REBUILD=
-fi
-AC_SUBST(REBUILD)
-
have_x=false
if test "x$pango_os_win32" != xyes; then
AC_PATH_XTRA
@@ -501,27 +485,8 @@ PKG_CHECK_MODULES(LIBTHAI, libthai >= $LIBTHAI_REQUIRED_VERSION, have_libthai=tr
#
# Checks for GObject Introspection
#
-have_introspection=false
-PKG_CHECK_MODULES(INTROSPECTION, gobject-introspection-1.0 >= 0.6.4, have_introspection=true, have_introspection=false)
-AM_CONDITIONAL(HAVE_INTROSPECTION, $have_introspection)
-
-G_IR_SCANNER=
-G_IR_COMPILER=
-G_IR_GENERATE=
-GIRDIR=
-TYPELIBDIR=
-if $have_introspection; then
- G_IR_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
- G_IR_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
- G_IR_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
- GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
- TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
-fi
-AC_SUBST(G_IR_SCANNER)
-AC_SUBST(G_IR_COMPILER)
-AC_SUBST(G_IR_GENERATE)
-AC_SUBST(GIRDIR)
-AC_SUBST(TYPELIBDIR)
+
+GOBJECT_INTROSPECTION_CHECK([0.6.14])
#
# Modules to build
@@ -605,7 +570,7 @@ for module in $included_modules; do
*-win32) INCLUDED_WIN32_MODULES="$INCLUDED_WIN32_MODULES $included_path" ;;
*-atsui) INCLUDED_ATSUI_MODULES="$INCLUDED_ATSUI_MODULES $included_path" ;;
*-lang) INCLUDED_LANG_MODULES="$INCLUDED_LANG_MODULES $included_path" ;;
- *) AC_MSG_ERROR([specified module $module not recognized]) ;;
+ *) IFS="$pango_save_ifs" AC_MSG_ERROR([specified module $module not recognized]) ;;
esac
done
IFS="$pango_save_ifs"
@@ -798,9 +763,9 @@ for module in $included_modules; do
module_c=`echo $module | sed s/-/_/`
cat >> pango/module-defs.h <<EOTEXT
extern void _pango_${module_c}_script_engine_list (PangoEngineInfo **engines, int *n_engines);
-extern PangoEngine *_pango_${module_c}_script_engine_init (GTypeModule *module);
+extern void _pango_${module_c}_script_engine_init (GTypeModule *module);
extern void _pango_${module_c}_script_engine_exit (void);
-extern void _pango_${module_c}_script_engine_create (const char *id);
+extern PangoEngine *_pango_${module_c}_script_engine_create (const char *id);
EOTEXT
done
@@ -1002,6 +967,7 @@ pango/mini-fribidi/Makefile
pango/pango.rc
pango/pangoft2.rc
pango/pangowin32.rc
+pango/pangocairo.rc
pango/pangox.rc
pango/pangoxft.rc
pango-view/Makefile
@@ -1020,6 +986,9 @@ docs/Makefile
docs/version.xml
tools/Makefile
tests/Makefile
+build/Makefile
+build/win32/Makefile
+build/win32/vs9/Makefile
pango.pc
pangox.pc
pangowin32.pc
@@ -1033,6 +1002,7 @@ pangoft2-uninstalled.pc
pangoxft-uninstalled.pc
pangocairo-uninstalled.pc
pango-zip.sh
+config.h.win32
])
AC_CONFIG_FILES([tests/runtests.sh],