summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2012-08-21 16:07:41 -0400
committerBehdad Esfahbod <behdad@behdad.org>2012-08-21 16:07:41 -0400
commit81af952c3715c4784ecf25999862e2683827834c (patch)
tree20abe38a78a72aad5434afa4f3d61af7e623cc63 /configure.in
parenta813e75a25459560c37f3eeed5455047a86d0500 (diff)
downloadpango-81af952c3715c4784ecf25999862e2683827834c.tar.gz
Fix build system
When harfbuzz is not found, we cannot enable cairo-ft backend.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 18 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 8485539a..bb2dfd0a 100644
--- a/configure.in
+++ b/configure.in
@@ -131,9 +131,8 @@ AC_TRY_COMPILE(,[class a { int b; } c;], ,CXX=)
AM_CONDITIONAL(HAVE_CXX, test "$CXX" != "")
AC_LANG_RESTORE
-#
-# Checks for HarfBuzz
-#
+
+
AC_PROG_CXX
AC_CHECK_FUNCS(mprotect sysconf getpagesize)
@@ -225,17 +224,30 @@ AC_ARG_ENABLE(rebuilds,
AM_CONDITIONAL(CROSS_COMPILING, [test $cross_compiling = yes])
-have_fontconfig=false
-have_freetype=false
+
+#
+# Checks for HarfBuzz
+#
+have_harfbuzz=false
+PKG_CHECK_MODULES(HARFBUZZ, harfbuzz >= 0.9.3, have_harfbuzz=true, AC_MSG_RESULT([no]))
+AM_CONDITIONAL(HAVE_HARFBUZZ, $have_harfbuzz)
+if ! $have_harfbuzz; then
+ have_freetype=false
+ have_xft=false
+fi
#
# Check for fontconfig
#
-PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 2.5.0, have_fontconfig=true, AC_MSG_RESULT([no]))
+have_fontconfig=false
+if $have_harfbuzz ; then
+ PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 2.5.0, have_fontconfig=true, AC_MSG_RESULT([no]))
+fi
#
# Checks for FreeType
#
+have_freetype=false
if $have_fontconfig ; then
# The first version of freetype with a .pc file is 2.1.5. That's recent
# enough for all the functions we use I guess. No version check needed.
@@ -431,15 +443,6 @@ AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype)
AM_CONDITIONAL(HAVE_CAIRO_QUARTZ, $have_cairo_quartz)
-harfbuzz_required=0.9
-have_harfbuzz=false
-PKG_CHECK_MODULES(HARFBUZZ, harfbuzz >= $harfbuzz_required, have_harfbuzz=true, have_harfbuzz=false)
-AM_CONDITIONAL(HAVE_HARFBUZZ, $have_harfbuzz)
-if ! $have_harfbuzz; then
- have_freetype=false
- have_xft=false
-fi
-
#
# We must have some backend defined, in order for the pango-querymodules
# rule in pango/Makefile.am to work correctly. If you are up to writing