summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-11-21 05:35:05 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-11-21 05:35:05 +0000
commit8a275434a1eb2b1a5d8c25b840b76ce86e1cf321 (patch)
tree2429b0c4f6ec6e2495c4a2c11b9f5b425294d59b /configure.in
parentceaeb6f33f43a9efe31e6549b3aad3d4a88a03e9 (diff)
downloadpango-8a275434a1eb2b1a5d8c25b840b76ce86e1cf321.tar.gz
Use some shell magic rather than perl to check for the right gtk-doc
Thu Nov 21 00:26:40 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Use some shell magic rather than perl to check for the right gtk-doc version to avoid having to worry about finding Perl. Make checks handle 0.10 > 0.9. (#99120, Dan Mills) Check for 0.10, since we need that for --output-format=xml.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 19 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index e39f6d7b..c865f575 100644
--- a/configure.in
+++ b/configure.in
@@ -540,22 +540,32 @@ fi
AC_SUBST(HTML_DIR)
+#
+# Check for sufficiently new gtk-doc
+#
+gtk_doc_min_version=0.10
AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
-
-gtk_doc_min_version=0.6
if $GTKDOC ; then
gtk_doc_version=`gtkdoc-mkdb --version`
AC_MSG_CHECKING([gtk-doc version ($gtk_doc_version) >= $gtk_doc_min_version])
- if perl <<EOF ; then
- exit (("$gtk_doc_version" =~ /^[[0-9]]+\.[[0-9]]+$/) &&
- ("$gtk_doc_version" >= "$gtk_doc_min_version") ? 0 : 1);
-EOF
+
+ IFS="${IFS= }"; pango_save_IFS="$IFS"; IFS="."
+ set $gtk_doc_version
+ for min in $gtk_doc_min_version ; do
+ cur=$1; shift
+ if test -z $min ; then break; fi
+ if test -z $cur ; then GTKDOC=false; break; fi
+ if test $cur -gt $min ; then break ; fi
+ if test $cur -lt $min ; then GTKDOC=false; break ; fi
+ done
+ IFS="$pango_save_IFS"
+
+ if $GTKDOC ; then
AC_MSG_RESULT(yes)
- else
+ else
AC_MSG_RESULT(no)
- GTKDOC=false
- fi
+ fi
fi
AM_CONDITIONAL(HAVE_GTK_DOC, $GTKDOC)