summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-16 10:28:12 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-16 10:28:12 +0000
commit08247583a00f69914682ba1807e4e377b6a98e48 (patch)
tree71be9f5df7560d239594244fef959026b4499a6d /configure.in
parentdb2b18526d6238b02c28208ec27d2fc18635bba0 (diff)
downloadpango-08247583a00f69914682ba1807e4e377b6a98e48.tar.gz
Fixes bug #314675, Brian Cameron.
2006-01-16 Behdad Esfahbod <behdad@gnome.org> Fixes bug #314675, Brian Cameron. * configure.in: Handle uninstalled cairo. * pangocairo-uninstalled.pc.in: Fix typo: libpangoxft->libpangocairo.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4409a411..9424b63d 100644
--- a/configure.in
+++ b/configure.in
@@ -287,7 +287,9 @@ PKG_CHECK_MODULES(CAIRO, cairo >= 0.5.2-head, have_cairo=true, :)
if $have_cairo ; then
pango_save_ldflags=$LDFLAGS
- LDFLAGS="$LDFLAGS $CAIRO_LIBS"
+ m4_pattern_allow([PKG_CONFIG_DISABLE_UNINSTALLED])
+ INSTALLED_CAIRO_LIBS=`PKG_CONFIG_DISABLE_UNINSTALLED=yes $PKG_CONFIG --libs cairo`
+ LDFLAGS="$LDFLAGS $INSTALLED_CAIRO_LIBS"
AC_CHECK_LIB(cairo, cairo_win32_scaled_font_select_font, have_cairo_win32=true, :)
if $have_cairo_win32 && $have_win32; then
AC_DEFINE(HAVE_CAIRO_WIN32, 1, [Whether Cairo uses the Win32 GDI for fonts])