summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-02-06 11:25:14 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-02-06 11:25:14 +0000
commit8c71138ba5500a3d1bf446357992e8f165101173 (patch)
treea453bbcc0fba741aba3b3e16074933407f60dccc /configure.in
parent9f81790eaec937ced41c31fb6204d63a377a00a7 (diff)
downloadpango-8c71138ba5500a3d1bf446357992e8f165101173.tar.gz
Bug 328067 – Install pango-view
2006-02-06 Behdad Esfahbod <behdad@gnome.org> Bug 328067 – Install pango-view Added a rather generic framework for a pango-view example. All backends have their own pango*-view built, and a pango-view binary is built too, that can choose backend via --backend. This one is installed in bindir. * examples/Makefile.am: Updated, to build pangox-view, pangoft2-view, pangoxft-view, pangocairo-view, and pango-view. * examples/viewer.h, examples/viewer-x.c, examples/viewer-x.h examples/viewer-cairo.c, examples/viewer-cairo.h, examples/viewer-main.c, examples/viewer-pangox.c, examples/viewer-pangoft2.c, examples/viewer-pangoxft.c, examples/viewer-pangocairo.c, examples/pango-view.c, examples/pango-xview.c, examples/pango-ft2view.c, examples/pango-xftview.c, examples/pango-cairoview.c: Added. * examples/cairoview.c, examples/xftview.c, examples/pangoft2topgm.c, examples/viewer-qt.cc, examples/viewer-qt.h: Removed. * configure.in: Check for Cairo Xlib backend, also AC_DEFINE various backend bits.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7778d077..cba667cb 100644
--- a/configure.in
+++ b/configure.in
@@ -242,12 +242,16 @@ if $have_fontconfig ; then
AC_SUBST(FREETYPE_LIBS)
AC_SUBST(FREETYPE_CFLAGS)
+ AC_DEFINE(HAVE_FREETYPE, 1, [Have FreeType 2 library])
#
# Checks for Xft/XRender
#
if $have_x && $have_freetype ; then
PKG_CHECK_MODULES(XFT, xft >= 2.0.0, have_xft=true, :)
+ if $have_xft ; then
+ AC_DEFINE(HAVE_XFT, 1, [Have Xft library])
+ fi
fi
else
AC_MSG_WARN([No fontconfig found, skipping tests for FreeType and Xft])
@@ -286,6 +290,7 @@ AC_CHECK_HEADER(Carbon/Carbon.h, [have_atsui=true], [have_atsui=true])
#
have_cairo=false
have_cairo_png=false
+have_cairo_xlib=false
have_cairo_freetype=false
have_cairo_win32=false
have_cairo_atsui=false
@@ -302,6 +307,10 @@ if $have_cairo ; then
if $have_cairo_png; then
AC_DEFINE(HAVE_CAIRO_PNG, 1, [Whether Cairo has PNG support])
fi
+ AC_CHECK_LIB(cairo, cairo_xlib_surface_create, have_cairo_xlib=true, :)
+ if $have_cairo_xlib; then
+ AC_DEFINE(HAVE_CAIRO_XLIB, 1, [Whether Cairo has Xlib support])
+ fi
have_cairo=false
AC_CHECK_LIB(cairo, cairo_win32_scaled_font_select_font, have_cairo_win32=true, :)
if $have_cairo_win32 && $have_win32; then
@@ -323,6 +332,7 @@ fi
AM_CONDITIONAL(HAVE_CAIRO, $have_cairo)
AM_CONDITIONAL(HAVE_CAIRO_PNG, $have_cairo_png)
+AM_CONDITIONAL(HAVE_CAIRO_XLIB, $have_cairo_xlib)
AM_CONDITIONAL(HAVE_CAIRO_WIN32, $have_cairo_win32 && $have_win32)
AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype && $have_freetype)
AM_CONDITIONAL(HAVE_CAIRO_ATSUI, $have_cairo_atsui && $have_atsui)