summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2005-01-09 00:12:39 +0000
committerOwen Taylor <otaylor@src.gnome.org>2005-01-09 00:12:39 +0000
commitcc6ac36dd3c7e5ef39b9f21ef77596a159f2100e (patch)
treee1b8ffc1c14d449a41946d22ea5d1c6ddf9115d8 /docs/Makefile.am
parent75f4ad29adce645ddb837e662c9d71ccfbf60154 (diff)
downloadpango-cc6ac36dd3c7e5ef39b9f21ef77596a159f2100e.tar.gz
Add checks for Cairo
Sat Jan 8 16:46:37 2005 Owen Taylor <otaylor@redhat.com> * configure.in: Add checks for Cairo * pango/Makefile.am: Add libpangocairo. * pango/pangocairo-font.c pango/pangocairo-fontmap.c pango/pangocairo.h pango/pangocairo-private.h pango/pangocairo-fcfont.c pango/pangocairo-fcfontmap.c pango/pangocairo-fc.h: Start of a Cairo/FreeType backend. * pango/pangofc-fontmap.[ch]: Add a "get_render_key" virtual function to allow subclasses to specialize the details of how caching works. Add a default implementation that's a little more sophisticated than what was there before. * pango/pangoft2-private.h pangofc-font.c pangoft2.c: Move default implementations of has_char(), get_glyph() to the base class. * pango/pangofc-private.h pango/pangoft2-private.h: Move PANGO_UNITS_26_6 and friends to pango/pangofc-private.h. * examples/renderdemo.[ch] examples/pangoft2topgm.c examples/xftview.c: Allow passing in a custom function to transform drawing. * examples/Makefile.am examples/cairoview.c: Add a Cairo/Xlib example program. * examples/cairosimple.c: Simple Cairo example with output to a PNG. * pango/pango-layout.c (pango_layout_line_get_extents): Fix bug where line ink rect was always including 0, 0.
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index e04dfaed..6d55e7f3 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -25,6 +25,8 @@ IGNORE_HFILES= \
module-defs.h \
opentype \
modules.h \
+ pangocairo-private.h \
+ pangocairo-fc.h \
pango-engine-private.h \
pango-impl-utils.h \
pango-glyph-item-private.h \
@@ -55,6 +57,9 @@ INCLUDES = \
GTKDOC_LIBS = \
$(top_builddir)/pango/libpangoxft-1.0.la
+if HAVE_CAIRO
+GTKDOC_LIBS += $(top_builddir)/pango/libpangocairo-1.0.la
+endif
# Extra options to supply to gtkdoc-mkdb
MKDB_OPTIONS=--sgml-mode --output-format=xml
@@ -68,7 +73,8 @@ content_files = \
# Images to copy into HTML directory
HTML_IMAGES = \
- layout.gif
+ layout.gif \
+ rotated-text.png
# Extra options to supply to gtkdoc-fixref
FIXXREF_OPTIONS=