summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-04-16 18:58:48 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-04-16 18:58:48 +0000
commit8794423e39341d2ebeec77fbce39ced5c18d8d2b (patch)
tree55c80457ab67cc73cbc9e51189060acbfb43e65d /docs/Makefile.am
parent6cf85a472ad1b8b8320d1bcb92a5c259c7ad32be (diff)
downloadpango-8794423e39341d2ebeec77fbce39ced5c18d8d2b.tar.gz
Update.
Mon Apr 16 14:26:54 2001 Owen Taylor <otaylor@redhat.com> * docs/pango-sections.txt: Update. * docs/Makefile.am (EXTRA_DIST): Update to the latest version.
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index baee93fa..d2d952e1 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -94,14 +94,14 @@ all-local: html-build.stamp
scan-build.stamp: $(HFILE_GLOB)
@echo '*** Scanning header files ***'
- cd $(srcdir) && ( \
- if grep -l '^..*$$' $(DOC_MODULE).types > /dev/null ; then \
- CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj --module=$(DOC_MODULE) ; \
+ if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null ; then \
+ CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
else \
+ cd $(srcdir) ; \
for i in $(SCANOBJ_FILES) ; do \
test -f $$i || touch $$i ; \
done \
- fi )
+ fi
cd $(srcdir) && \
gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
touch scan-build.stamp
@@ -181,11 +181,12 @@ dist-hook: dist-check-gtkdoc dist-hook-local
mkdir $(distdir)/html
-cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
-cp $(srcdir)/sgml/*.sgml $(distdir)/sgml
- -cp $(srcdir)/sgml/*.bottom $(srcdir)/sgml/*.top $(distdir)/sgml
-cp $(srcdir)/html/index.sgml $(distdir)/html
-cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
- for i in $(HTML_IMAGES) ; do \
+
+ images=$(HTML_IMAGES) ; \
+ for i in $$images ; do \
cp $(srcdir)/$$i $(distdir)/html ; \
- done
+ done
.PHONY : dist-hook-local