summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-10-29 05:48:16 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-10-29 05:48:16 +0000
commit4cda3f186493ed8e6c3872a1deee080fd601e6df (patch)
tree2b5fb6479609639a2d258025987bb267448d4b75 /docs/Makefile.am
parent50c23bd38e97cbe6dd1c5285aad3fa3ceeda8804 (diff)
downloadpango-4cda3f186493ed8e6c3872a1deee080fd601e6df.tar.gz
Fix up doc comments not to have obvious errors that gtk-doc barfs on.
Sun Oct 29 01:27:39 2000 Owen Taylor <otaylor@redhat.com> * pango/pangoft2-fontcache.c pango/pangoft2.[ch] pango/pangowin32.h: Fix up doc comments not to have obvious errors that gtk-doc barfs on. Correct parameter descriptions still need to be filled in. * configure.in pango/docs/Makefile.am: upgrade to have a real install rule, etc. * pango/docs/pango-sections.txt: Add various missing functions.
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am136
1 files changed, 101 insertions, 35 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 7e8074fc..b4fd8669 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -1,59 +1,125 @@
## Process this file with automake to create Makefile.in.
-pangoheaders = \
- ../pango/pango.h \
- ../pango/pango-attributes.h \
- ../pango/pango-context.h \
- ../pango/pango-coverage.h \
- ../pango/pango-engine.h \
- ../pango/pango-font.h \
- ../pango/pango-fontmap.h \
- ../pango/pango-glyph.h \
- ../pango/pango-item.h \
- ../pango/pango-layout.h \
- ../pango/pango-types.h \
- ../pango/pangox.h
-
-if HAVE_GTK_DOC
-
# The name of the module.
DOC_MODULE=pango
# The top-level SGML file.
DOC_MAIN_SGML_FILE=pango-docs.sgml
-SOURCE_DIR=../pango
+# The directory containing the source code
+DOC_SOURCE_DIR=$(top_srcdir)/pango
+
+# Extra options to supply to gtkdoc-fixref
+FIXXREF_OPTIONS=
+
+# Headers to ignore
+IGNORE_HFILES= \
+ modules.h \
+ pango-utils.h \
+ pangoft2-private.h \
+ pangowin32-private.h \
+ pangox-private.h
+
+tmpl_sources = \
+ tmpl/coverage-maps.sgml \
+ tmpl/engines.sgml \
+ tmpl/fonts.sgml \
+ tmpl/freetype-fonts.sgml \
+ tmpl/glyphs.sgml \
+ tmpl/layout.sgml \
+ tmpl/main.sgml \
+ tmpl/modules.sgml \
+ tmpl/tab-stops.sgml \
+ tmpl/text-attributes.sgml \
+ tmpl/win32-fonts.sgml \
+ tmpl/x-fonts.sgml \
+ tmpl/x-rendering.sgml
+
+
+####################################
+# Everything below here is generic #
+####################################
+
+TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+EXTRA_DIST = \
+ $(DOC_MAIN_SGML_FILE) \
+ $(DOC_MODULE)-decl.txt \
+ $(DOC_MODULE)-sections.txt \
+ $(DOC_MODULE)-overrides.txt
+
+if ENABLE_GTK_DOC
+all-local: html/index.html
+
+$(DOC_MODULE)-decl.txt:
+ $(MAKE) scan
+
+$(tmpl_sources): $(DOC_MODULE)-decl.txt $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt
+ $(MAKE) templates
+
+sgml/$(DOC_MODULE)-doc.bottom: $(tmpl_sources) $(DOC_MODULE)-decl.txt
+ $(MAKE) sgml
+
+html/index.html: sgml/$(DOC_MODULE)-doc.bottom $(DOC_MAIN_SGML_FILE)
+ $(MAKE) html
+endif
scan:
- gtkdoc-scan --module=$(DOC_MODULE) $(pangoheaders)
+ -(cd $(srcdir) \
+ && gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" )
-templates: scan
- gtkdoc-mktmpl --module=$(DOC_MODULE)
+templates:
+ cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE)
sgml:
- gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(SOURCE_DIR)
+ cd $(srcdir) \
+ && gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR)
html:
- if ! test -d html ; then mkdir html ; fi
- -cd html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
- cp layout.gif html
+ test -d $(srcdir)/html || mkdir $(srcdir)/html
+ -cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+ @echo '-- Fixing Crossreferences'
+ cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
clean-local:
- rm -f *~ *.bak *.hierarchy *.signals *.args *-unused.txt
+ rm -f *~ *.bak *.signals *-unused.txt
maintainer-clean-local: clean
- rm -rf sgml html $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
+ cd $(srcdir) && rm -rf sgml html $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
-.PHONY: scan sgml html templates
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR)
+ (installfiles=`echo $(srcdir)/html/*.html`; \
+ if test "$$installfiles" = '$(srcdir)/html/*.html'; \
+ then echo '-- Nothing to install' ; \
+ else \
+ for i in $$installfiles; do \
+ echo '-- Installing '$$i ; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
+ done; \
+ echo '-- Installing $(srcdir)/html/index.sgml' ; \
+ $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR); \
+ fi)
+#
+# Require gtk-doc when making dist
+#
+if ENABLE_GTK_DOC
+dist-check-gtkdoc:
+else
+dist-check-gtkdoc:
+ @echo "*** gtk-doc must be installed and enabled in order to make dist"
+ @false
endif
-EXTRA_DIST=pango-sections.txt pango-docs.sgml layout.fig layout.eps layout.fig
-
-dist-hook:
+dist-hook: dist-check-gtkdoc
mkdir $(distdir)/tmpl
- cp -p $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
- mkdir $(distdir)/TEXT
- for i in $(srcdir)/TEXT/* ; do \
- test -f $$i && cp -p $$i $(distdir)/TEXT ; \
- done
+ mkdir $(distdir)/sgml
+ mkdir $(distdir)/html
+ -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
+ -cp $(srcdir)/sgml/*.sgml $(distdir)/sgml
+ -cp $(srcdir)/sgml/*.bottom $(srcdir)/sgml/*.top $(distdir)/sgml
+ -cp $(srcdir)/html/index.sgml $(distdir)/html
+ -cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
+
+.PHONY : html sgml templates scan