summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-10-24 04:11:12 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-10-24 04:11:12 +0000
commit7889367ae9a339da057e89b69362f557a16429ea (patch)
tree9b954fe698141644c5d0c4a0e273f21f69b7ab6d /docs/Makefile.am
parentd16d1bc261e772f64b377171ca7884b92c1d7288 (diff)
downloadpango-7889367ae9a339da057e89b69362f557a16429ea.tar.gz
=== Released 1.3.0 ===PANGO_1_3_0
Fri Oct 24 00:09:17 2003 Owen Taylor <otaylor@redhat.com> * === Released 1.3.0 === * pango/module-defs-fc.c.win32 pango/module-defs-fc.c.win32: Add the -fc version, remove the -ft2 version. Not sure this file is actually needed any more. * pango/Makefile.am (libpango_1_0_la_SOURCES): Add pango-impl-utils.h, pango-script-lang-table.h. * docs/Makefile.am (dist-hook-local): Distribute generated manpage. * tests/Makefile.am (CLEANFILES): Add pango.modules
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 63814d94..aaa468f3 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -71,6 +71,10 @@ HTML_IMAGES = \
# Extra options to supply to gtkdoc-fixref
FIXXREF_OPTIONS=
+include $(top_srcdir)/gtk-doc.make
+
+########################################################################
+
man_MANS = pango-querymodules.1
if ENABLE_MAN
@@ -80,17 +84,20 @@ if ENABLE_MAN
endif
-include $(top_srcdir)/gtk-doc.make
-
EXTRA_DIST += \
layout.fig \
layout.eps \
version.xml.in
-
+BUILT_EXTRA_DIST = $(man_MANS)
dist-hook-local:
- mkdir $(distdir)/TEXT; \
- for f in $(srcdir)/TEXT/* ; do \
- test -f $$f && cp -p $$f $(distdir)/TEXT; \
+ files='$(BUILT_EXTRA_DIST)'; \
+ for f in $$files; do \
+ if test -f $$f; then d=.; else d=$(srcdir); fi; \
+ cp $$d/$$f $(distdir) || exit 1; done; \
+ \
+ mkdir $(distdir)/TEXT; \
+ for f in $(srcdir)/TEXT/* ; do \
+ test -f $$f && cp -p $$f $(distdir)/TEXT; \
done