summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@src.gnome.org>2000-01-13 04:12:07 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-01-13 04:12:07 +0000
commit282fb5fc9f9d01c4d933a6eb6bee6ae9f0d512c7 (patch)
tree0b19c69692a2fe52a1b33d5e27c97b26a64417e3 /docs/Makefile.am
parent66ae87f9fc45f5f564acf5014e9bd1341d052958 (diff)
downloadpango-282fb5fc9f9d01c4d933a6eb6bee6ae9f0d512c7.tar.gz
Initial revision
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 00000000..255916d5
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,45 @@
+## Process this file with automake to create Makefile.in.
+
+if HAVE_GTK_DOC
+
+# The name of the module.
+DOC_MODULE=pango
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=pango-docs.sgml
+
+INCLUDE_DIR=../libpango
+SOURCE_DIR=../libpango
+
+scan:
+ gtkdoc-scan --module=$(DOC_MODULE) $(INCLUDE_DIR)/pango*.h
+
+templates: scan
+ gtkdoc-mktmpl --module=$(DOC_MODULE)
+
+sgml:
+ gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(SOURCE_DIR)
+
+html:
+ if ! test -d html ; then mkdir html ; fi
+ -cd html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+
+clean-local:
+ rm -f *~ *.bak *.hierarchy *.signals *.args *-unused.txt
+
+maintainer-clean-local: clean
+ rm -rf sgml html $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
+
+.PHONY: scan sgml html templates
+
+endif
+
+EXTRA_DIST=pango-sections.txt pango-docs.sgml
+
+dist-hook:
+ mkdir $(distdir)/tmpl
+ cp -p $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
+ mkdir $(distdir)/TEXT
+ for i in $(srcdir)/TEXT/* ; do \
+ test -f $$i && cp -p $$i $(distdir)/TEXT ;\
+ done