summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-09-15 19:54:39 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-09-15 19:54:39 +0000
commit0bb8e3c03a4b0de57366cdde64a2b35cb55ed216 (patch)
treebce4b1174634ff36c6f32b13b50d90ef06ddc9ad /examples/Makefile.am
parent48254364ad24eaa6d34f4f58a2f960695a80b8d0 (diff)
downloadpango-0bb8e3c03a4b0de57366cdde64a2b35cb55ed216.tar.gz
Borrow argument parsing code from GDK.
Mon Sep 15 15:48:25 2003 Owen Taylor <otaylor@redhat.com> * examples/Makefile.am examples/argcontext.c examples/argcontext.h: Borrow argument parsing code from GDK. * examples/pangoft2topgm.c: Use argcontext.[ch]. Add options --header to display options in a header in the image, --text to pass the text on the command line, --width to set a wrap width. Add autoconversion to non-PGM output formats via 'convert' for --output="foo.png" etc.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 9b451564..f13b957d 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -21,7 +21,10 @@ if HAVE_FREETYPE
ft2_programs = pangoft2topgm
endif
-pangoft2topgm_SOURCES = pangoft2topgm.c
+pangoft2topgm_SOURCES = \
+ pangoft2topgm.c \
+ argcontext.c \
+ argcontext.h
pangoft2topgm_LDADD = \
../pango/libpango-$(PANGO_API_VERSION).la \
../pango/libpangoft2-$(PANGO_API_VERSION).la \