summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-23 16:27:21 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-23 16:27:21 +0000
commit8b728035f9cfe490ba109494eb8564d11552e374 (patch)
tree2cc04257fd0293666366d066fc5edac2fa382474 /examples/Makefile.am
parentce22d934fce30c8fce9b660221419f8a0055d565 (diff)
downloadpango-8b728035f9cfe490ba109494eb8564d11552e374.tar.gz
Make tests/examples do use generated pango.modules. (bug #328291)
2006-01-23 Behdad Esfahbod <behdad@gnome.org> Make tests/examples do use generated pango.modules. (bug #328291) * examples/pangorc, tests/pangorc: Removed. Moved to modules/. * examples/pangox.aliases: Removed. Moved to pango/. * examples/Makefile.am, tests/Makefile.am: Remove pango.modules creation stuff, copy pangorc from $(srcdir)/../modules/pangorc insteadd. * examples/renderdemo.c: Add --pangorc option, default to ./pangorc. Setenv PANGO_RC_FILE to whatever pangorc file decided. * tests/*.c: Setenv PANGO_RC_FILE to ./pangorc. * pango/pangox.aliases: Added. * pango/Makefile.am: Install pangox.aliases. * modules/pangorc: Added. * modules/Makefile.am: Create pango.modules. Added pangorc. * modules/.cvsignore, examples/.cvsignore, tests/.cvsignore: Updated.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am50
1 files changed, 14 insertions, 36 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index f41174f0..d884f122 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,6 +1,16 @@
## Process this file with automake to create Makefile.in.
-aliasdir = $(sysconfdir)/pango
+EXTRA_DIST= \
+ viewer-win32.c \
+ makefile.msc \
+ HELLO.utf8 \
+ GLASS.utf8 \
+ dev-example.utf \
+ muru.utf \
+ syriac.utf \
+ tibetan.utf
+
+CLEANFILES = pangorc
INCLUDES = \
-DG_DISABLE_DEPRECATED \
@@ -13,11 +23,6 @@ INCLUDES = \
$(FREETYPE_CFLAGS) \
$(X_CFLAGS)
-###################################################
-
-CLEANFILES = pango.modules
-###################################################
-
noinst_PROGRAMS =
###################################################
@@ -94,34 +99,7 @@ cairosimple_LDADD = \
$(CAIRO_LIBS)
###################################################
-if CROSS_COMPILING
-else
-all-local: pango.modules
-endif
-
-pango.modules: $(top_builddir)/pango/pango-querymodules
- if find ../modules -name '*.so' | grep 'so' > /dev/null ; then \
- echo "Writing a pango.modules file to use when running examples before installing Pango."; \
- (cd ../modules && \
- $(top_builddir)/pango/pango-querymodules `find . -name '*.la' | grep -v \.libs | grep -v libpango` > ../examples/pango.modules ) ;\
- else \
- echo "No dynamic modules found; will use only static modules for not-installed example programs."; \
- touch pango.modules; \
- fi
+pangorc: $(srcdir)/../modules/pangorc
+ cp $< $@
-EXTRA_DIST= \
- viewer-win32.c \
- pangoft2topgm.c \
- makefile.msc \
- HELLO.utf8 \
- GLASS.utf8 \
- dev-example.utf \
- muru.utf \
- syriac.utf \
- tibetan.utf \
- pangorc \
- pangox.aliases
-
-if HAVE_X
-alias_DATA = pangox.aliases
-endif
+$(noinst_PROGRAMS): pangorc