summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-03-13 15:59:09 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-03-13 15:59:09 +0000
commita6128c9efba496a2193894ec9ebe7a14404df72e (patch)
treeae1e9c9be775c9b2fe75e51c33b2a9ebd69a272a /examples/Makefile.am
parentdf19b2f5a156b717186f8cbc6b1ad39d2401ab90 (diff)
downloadpango-a6128c9efba496a2193894ec9ebe7a14404df72e.tar.gz
Memory management functions for PangoItem.
Mon Mar 13 10:54:48 2000 Owen Taylor <otaylor@redhat.com> * pango/pango-item.[ch]: Memory management functions for PangoItem. * pango/*.[ch]: Random constification. * pango/pangox.c pango/pango-layout.c pango/pango-context.c: Add an extra_attrs field to PangoItem. Use this to handle underlining for PangoLayout. * examples/viewer.c (reload_font): Make paragraphs global to save the complexity of passing it around all over the place. * pango/pango-layout.[ch] (pango_layout_context_changed): Add a function to reset the layout on changes to the layout's context. * pango/pangox.c (pango_x_make_matching_xlfd): Prefer bitmap to scaleable if the discrepancy is < 1 pixel. (Probably not the ideal criterion.) * pango/pangox.c (pango_x_font_map_for_display): Fix resolution computation error. * pango/pango-layout.c (pango_layout_check_lines): Handle text with embedded newlines. * pango/pangox.c (pango_x_render_layout): Fix y to refer to the top of the layout, not the baseline of the first line. * pango/pango-layout.c (process_item): Don't wrap if width is set to -1. * Makefile.am configure.in **/*.[ch]: move libpango/ directory and fix all headers to install under include/pango/
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index b794125f..784afb85 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -2,21 +2,21 @@
aliasdir = $(sysconfdir)/pango
-INCLUDES = -I$(top_srcdir)/libpango/
+INCLUDES = -I$(top_srcdir)
if BUILD_TESTS
bin_PROGRAMS = pango-viewer
pango_viewer_SOURCES = \
viewer.c
-pango_viewer_LDADD = ../libpango/libpango.la ../libpango/libpangox.la $(GTK_LIBS) -lfribidi $(UNICODE_LIBS)
+pango_viewer_LDADD = ../pango/libpango.la ../pango/libpangox.la $(GTK_LIBS) -lfribidi $(UNICODE_LIBS)
endif
all-local: pango.modules
pango.modules:
( cd ../modules && \
- ../libpango/pango-querymodules `find . -name '*.so'` > ../examples/pango.modules )
+ ../pango/pango-querymodules `find . -name '*.so'` > ../examples/pango.modules )
EXTRA_DIST=HELLO.utf8 muru.utf pangox_aliases