summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2004-07-10 22:11:49 +0000
committerOwen Taylor <otaylor@src.gnome.org>2004-07-10 22:11:49 +0000
commitbfafb05de97e187fbbb85c83f4c7b59203a62439 (patch)
tree4485cb0ce5e8364caea44b9e4d967905769f07b1 /examples/Makefile.am
parentbd2b21c9f509b3e2f518980b05d56f3d0dd4f2a7 (diff)
downloadpango-bfafb05de97e187fbbb85c83f4c7b59203a62439.tar.gz
Split most of the guts of pangoft2topgm.c into separate source files to
Sat Jul 10 18:06:21 2004 Owen Taylor <otaylor@redhat.com> * examples/renderdemo.[ch] examples/Makefile.am examples/pangoft2topgm.c: Split most of the guts of pangoft2topgm.c into separate source files to allow creation of new rendering demos for different backends.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index f13b957d..e5834148 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -16,13 +16,17 @@ INCLUDES = \
CLEANFILES = pango.modules
###################################################
+noinst_PROGRAMS =
+
###################################################
if HAVE_FREETYPE
-ft2_programs = pangoft2topgm
+noinst_PROGRAMS += pangoft2topgm
endif
pangoft2topgm_SOURCES = \
pangoft2topgm.c \
+ renderdemo.c \
+ renderdemo.h \
argcontext.c \
argcontext.h
pangoft2topgm_LDADD = \
@@ -31,8 +35,6 @@ pangoft2topgm_LDADD = \
$(FREETYPE_LIBS)
###################################################
-noinst_PROGRAMS = $(ft2_programs)
-
if CROSS_COMPILING
else
all-local: pango.modules