summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2017-05-22 21:53:30 +0200
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-22 20:57:58 +0100
commit6f59d0f387dd62f12a7107e898064c7e42159945 (patch)
tree6ecea57882b4f6c49a9b368ad90f7c470485580f /meson.build
parent58442456e6736fbe0d46d55bf32acba881aad853 (diff)
downloadpango-6f59d0f387dd62f12a7107e898064c7e42159945.tar.gz
meson: Generate correct sonames
"soversion:" is for the version placed in the soname. The full library revision goes into "version:". This affects the symlinks, too.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1a0ff0e4..368f3317 100644
--- a/meson.build
+++ b/meson.build
@@ -37,7 +37,8 @@ pango_conf.set('PANGO_VERSION_MINOR', pango_minor_version)
pango_conf.set('PANGO_VERSION_MICRO', pango_micro_version)
# Maintain version scheme with libtool
-pango_soversion = '0.@0@.@1@'.format((pango_binary_age - pango_interface_age), pango_interface_age)
+pango_soversion = 0
+pango_libversion = '@0@.@1@.@2@'.format(pango_soversion, (pango_binary_age - pango_interface_age), pango_interface_age)
cc = meson.get_compiler('c')
host_system = host_machine.system()