summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2019-05-25 12:06:24 -0400
committerMatthias Clasen <mclasen@redhat.com>2019-05-25 12:06:24 -0400
commit0b45000de8d31ca8cfe6b44f9f0ac309db5899dc (patch)
treed8db8499bb900209a0a5af5f59daac4f1aaab4d7 /meson.build
parent82245395077a768abc161e112c18cec9aa4834c7 (diff)
downloadpango-0b45000de8d31ca8cfe6b44f9f0ac309db5899dc.tar.gz
Fix building glib as subproject
This is necessary now, since we bumped the glib req beyond what the stable gnom eruntime currently provides.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c9bf217e..db073d6a 100644
--- a/meson.build
+++ b/meson.build
@@ -4,7 +4,9 @@ project('pango', 'c', 'cpp',
default_options: [
'buildtype=debugoptimized',
'warning_level=1',
- 'c_std=c99',
+ # We only need c99, but glib needs GNU-specific features
+ # https://github.com/mesonbuild/meson/issues/2289
+ 'c_std=gnu99',
],
meson_version : '>= 0.48.0')