summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2019-07-27 21:28:10 +0000
committerKhaled Hosny <khaledhosny@eglug.org>2019-07-27 21:28:10 +0000
commitd8795e05687e12394006f170c219b78debc66c3f (patch)
tree5a9ec0e662d61707b87e7fe76e69bde0ed96130d /meson.build
parent08b1a57826fdcf1386b26b25cbb23b82b4a51be4 (diff)
parent2eaa4feab269436b3dadc6b058236c19086960e0 (diff)
downloadpango-d8795e05687e12394006f170c219b78debc66c3f.tar.gz
Merge branch 'darwin-versions-fix' into 'master'
meson: fix darwin_versions See merge request GNOME/pango!105
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6fa41085..6db9b397 100644
--- a/meson.build
+++ b/meson.build
@@ -42,7 +42,8 @@ pango_conf.set('PANGO_VERSION_MICRO', pango_micro_version)
# Maintain version scheme with libtool
pango_soversion = 0
pango_libversion = '@0@.@1@.@2@'.format(pango_soversion, (pango_binary_age - pango_interface_age), pango_interface_age)
-pango_osxversion = pango_binary_age + 1
+osx_current = pango_binary_age - pango_interface_age + 1
+pango_osxversion = [osx_current, '@0@.@1@.0'.format(osx_current, pango_interface_age)]
cc = meson.get_compiler('c')
host_system = host_machine.system()