summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuca Bacci <luca.bacci982@gmail.com>2022-03-10 16:15:14 +0100
committerMatthias Clasen <mclasen@redhat.com>2022-06-22 13:54:01 -0400
commit2779e5a3d69e557707e33722ef9e3499492270c5 (patch)
tree0f46cd58437dc21e9c5d3966320bb99bcd9edce3 /meson.build
parent4aebe7a127799ba0d2de6c3f9c504077447376ac (diff)
downloadpango-2779e5a3d69e557707e33722ef9e3499492270c5.tar.gz
Add support for C++ to Meson build definitions
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 057093ae..5e2a9433 100644
--- a/meson.build
+++ b/meson.build
@@ -46,6 +46,7 @@ osx_current = pango_binary_age - pango_interface_age + 1
pango_osxversion = [osx_current, '@0@.@1@.0'.format(osx_current, pango_interface_age)]
cc = meson.get_compiler('c')
+cxx = meson.get_compiler('cpp')
host_system = host_machine.system()
# Compiler and linker flags
@@ -58,7 +59,7 @@ if cc.get_id() == 'msvc'
# Compiler options taken from msvc_recommended_pragmas.h
# in GLib, based on _Win32_Programming_ by Rector and Newcomer
test_cflags = ['-FImsvc_recommended_pragmas.h', '-utf-8']
- add_project_arguments(cc.get_supported_arguments(test_cflags), language: 'c')
+ add_project_arguments(cc.get_supported_arguments(test_cflags), language: ['c', 'cpp'])
test_c_only_flags = []
elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
test_c_only_flags = [