summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2019-07-24 15:58:06 +0000
committerMatthias Clasen <mclasen@redhat.com>2019-07-24 15:58:06 +0000
commitdd3fc1b1976890bde122c87813f03da6c26129b9 (patch)
tree7d8fe20fe00cbf3bd1b7096c8856a13be9c17174 /meson.build
parentf9ea5ab615c14b403f61ddb0ed8636f84e030b42 (diff)
parent39edaf261b17d5c4bea7a02750c3f5f4e1545d06 (diff)
downloadpango-dd3fc1b1976890bde122c87813f03da6c26129b9.tar.gz
Merge branch 'Jehan/fix-MinGW64-build' into 'master'
meson: do not set -Werror=redundant-decls for gcc on Windows target. See merge request GNOME/pango!41
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d690aec5..72198036 100644
--- a/meson.build
+++ b/meson.build
@@ -85,7 +85,6 @@ elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
'-Wlogical-op',
'-Wno-uninitialized',
'-Wno-shadow',
- '-Werror=redundant-decls',
'-Werror=implicit',
'-Werror=nonnull',
'-Werror=init-self',
@@ -106,6 +105,8 @@ elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
if host_system == 'windows'
test_cflags += [ '-mms-bitfields' ]
+ else
+ test_cflags += [ '-Werror=redundant-decls' ]
endif
else
test_cflags = []