summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2019-07-19 18:23:21 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2019-07-19 18:23:21 +0800
commit77e77bcf8897a58cd29a44ce1ce85e99ac28635b (patch)
tree7722103db2ec0f1a74617ed473c726b8c3b184d6 /meson.build
parent039f842773df8e5cb56c8840d2741bbc321a3ed7 (diff)
downloadpango-77e77bcf8897a58cd29a44ce1ce85e99ac28635b.tar.gz
build: Only use fallback for Cairo dep when necessary
Only use the fallback when we are sure that we can't find the Cairo headers and libraries, where applicable, and ensure that it is used, as it is really a hard dependency.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 13d9bbff..519251f2 100644
--- a/meson.build
+++ b/meson.build
@@ -343,8 +343,7 @@ if host_system == 'darwin'
endif
cairo_found_type = ''
-cairo_dep = dependency('cairo', version: cairo_req_version, required: false,
- fallback: ['cairo', 'libcairo_dep'])
+cairo_dep = dependency('cairo', version: cairo_req_version, required: false)
if cairo_dep.found()
cairo_found_type = cairo_dep.type_name()
@@ -355,6 +354,14 @@ else
endif
endif
+# Remove once Meson gains capability to declare dependencies
+# in a declarative way
+if not cairo_dep.found()
+ cairo_dep = dependency('cairo', version: cairo_req_version,
+ fallback: ['cairo', 'libcairo_dep'])
+ cairo_found_type = cairo_dep.type_name()
+endif
+
pango_font_backends = []
pango_cairo_backends = []